diff options
author | Pedro A. López-Valencia | 2021-06-05 13:50:39 -0500 |
---|---|---|
committer | Pedro A. López-Valencia | 2021-06-05 13:50:39 -0500 |
commit | dca21d899ec2b1390526a300c7a617a22165dbda (patch) | |
tree | 6cdad60a4f66846baf404cda72445697e1660156 | |
parent | e065d2a6c2cc1da1ff0faca0af78a4d89789e21f (diff) | |
download | aur-dca21d899ec2b1390526a300c7a617a22165dbda.tar.gz |
* Change behavior of changing directory ownership during packaging
to a post_install routine. Thus, builds can be chrooted.
-rw-r--r-- | .SRCINFO | 6 | ||||
-rw-r--r-- | PKGBUILD | 13 | ||||
-rw-r--r-- | emacs-git.install | 8 |
3 files changed, 19 insertions, 8 deletions
@@ -1,8 +1,9 @@ pkgbase = emacs-git pkgdesc = GNU Emacs. Development master branch. - pkgver = 28.0.50.148045 + pkgver = 28.0.50.148607 pkgrel = 1 url = http://www.gnu.org/software/emacs/ + install = emacs-git.install arch = x86_64 license = GPL3 makedepends = git @@ -35,8 +36,7 @@ pkgbase = emacs-git replaces = emacs-seq replaces = emacs-nox options = !strip - source = emacs-git::git://git.savannah.gnu.org/emacs.git + source = emacs-git::git://github.com/emacs-mirror/emacs.git b2sums = SKIP pkgname = emacs-git - @@ -59,7 +59,7 @@ if [[ $CLI == "YES" ]] ; then else pkgname="emacs-git" fi -pkgver=28.0.50.148045 +pkgver=28.0.50.148607 pkgrel=1 pkgdesc="GNU Emacs. Development master branch." arch=('x86_64') @@ -71,10 +71,11 @@ makedepends=('git') provides=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox') conflicts=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox') replaces=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox') -source=("emacs-git::git://git.savannah.gnu.org/emacs.git") +#source=("emacs-git::git://git.savannah.gnu.org/emacs.git") # If Savannah fails for reasons, use Github's mirror -#source=("emacs-git::git://github.com/emacs-mirror/emacs.git") +source=("emacs-git::git://github.com/emacs-mirror/emacs.git") options=(!strip) +install="$pkgname".install b2sums=('SKIP') ################################################################################ @@ -305,13 +306,15 @@ package() { if [[ $DOCS_PDF == "YES" ]]; then make DESTDIR="$pkgdir/" install-pdf; fi # fix user/root permissions on usr/share files - find "$pkgdir"/usr/share/emacs/ | xargs chown root:root + # MOVED to install script + # find "$pkgdir"/usr/share/emacs/ | xargs chown root:root # fix permssions on /var/games mkdir -p "$pkgdir"/var/games/emacs chmod 775 "$pkgdir"/var/games chmod 775 "$pkgdir"/var/games/emacs - chown -R root:games "$pkgdir"/var/games + # MOVED to install script + # chown -R root:games "$pkgdir"/var/games } diff --git a/emacs-git.install b/emacs-git.install new file mode 100644 index 000000000000..61ca576ee87f --- /dev/null +++ b/emacs-git.install @@ -0,0 +1,8 @@ +post_install() { + # fix user/root permissions on usr/share files + find "$pkgdir"/usr/share/emacs/ | xargs chown root:root + # make sure directory has the correct owner and group + chown -R root:games "$pkgdir"/var/games +} + +# vim:sw=4:ts=4:et:ft=bash |