summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commitb1ab746d4f16f09ce9979e40680131ba98d89172 (patch)
tree3fc3c55a7184726c4de79c90908f4d637a4a8ba7
downloadaur-emu8051.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87ff43eedd81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = emu8051
+ pkgdesc = Emulator and simulator for 8051 microcontrollers
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = http://www.hugovil.com/fr/emu8051/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gtk2
+ source = http://www.hugovil.com/repository/emu8051/emu8051-2.0.1.tar.gz
+ sha256sums = 9546066c662ba4e99a20477ec18d20f48a78bbd326868c286d21427b4b3d6a28
+
+pkgname = emu8051
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a69a864e5e4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Arthur Zamarin <arthurzam@gmail.com>
+
+pkgname=emu8051
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Emulator and simulator for 8051 microcontrollers"
+arch=(i686 x86_64)
+url="http://www.hugovil.com/fr/emu8051/index.html"
+license=('GPL2')
+depends=('gtk2')
+source=("http://www.hugovil.com/repository/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('9546066c662ba4e99a20477ec18d20f48a78bbd326868c286d21427b4b3d6a28')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure "--prefix=/usr"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR=$pkgdir install
+}