summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Kinnaird2019-11-12 13:01:33 -0600
committerJustin Kinnaird2019-11-12 13:01:33 -0600
commitb83d62d8e8668c35144de495beee3f94acafd236 (patch)
treece602e8897fc2e51c5b3627680cc149fe6ae7d27
parent38c936c7631bc7085d700c0b619fe4e7f5a48ba0 (diff)
downloadaur-emulationstation-fcamod-git.tar.gz
Add .desktop file and clean up dependencies
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
-rw-r--r--emulationstation.desktop9
3 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04bfc36614ac..1c872e01efed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emulationstation-fcamod-git
pkgdesc = A graphical front-end for emulators with controller navigation, with fcamod
pkgver = r1685.bbcd68d6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fabricecaruso/EmulationStation
arch = i686
arch = x86_64
@@ -16,23 +16,20 @@ pkgbase = emulationstation-fcamod-git
makedepends = mesa
makedepends = libsm
makedepends = rapidjson
- depends = alsa-lib
- depends = sdl2
+ makedepends = glu
depends = sdl2_mixer
- depends = boost-libs
depends = freeimage
- depends = ttf-dejavu
- depends = glu
depends = vlc
- depends = libcec
- depends = libgl
+ depends = curl
provides = emulationstation
conflicts = emulationstation
conflicts = emulationstation-git
source = emulationstation-fcamod-git::git+https://github.com/fabricecaruso/EmulationStation.git
source = share-dir.patch
+ source = emulationstation.desktop
sha512sums = SKIP
sha512sums = 72dcac3938c62ecda365bb50088658828d3876aa01d6a9ad21cb1b05da41f7defdee856ff353ab7b37d17a7f0b1e56d862e0da2da2b109e0dde3f8656a7848be
+ sha512sums = 00ddb6f2175290bf2cdb1fdee371c13fe67776b5222c9d79d3c1db1755d08d4cdae4f344d8131f97ef534d7e76dd2dc768f0ff49a41d0a8ee88fe44d4040e485
pkgname = emulationstation-fcamod-git
diff --git a/PKGBUILD b/PKGBUILD
index 15707fc50633..eaa2ff2a9009 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,23 @@
pkgname=emulationstation-fcamod-git
pkgdesc="A graphical front-end for emulators with controller navigation, with fcamod"
-pkgrel=1
+pkgrel=2
pkgver=r1685.bbcd68d6
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://github.com/fabricecaruso/EmulationStation"
license=('MIT')
-depends=('alsa-lib' 'sdl2' 'sdl2_mixer' 'boost-libs' 'freeimage' 'ttf-dejavu' 'glu' 'vlc' 'libcec')
-makedepends=('git' 'boost' 'freetype2' 'eigen' 'cmake' 'mesa' 'libsm' 'rapidjson')
+depends=('sdl2_mixer' 'freeimage' 'vlc' 'curl')
+makedepends=('git' 'boost' 'freetype2' 'eigen' 'cmake' 'mesa' 'libsm' 'rapidjson' 'glu')
conflicts=('emulationstation' 'emulationstation-git')
provides=('emulationstation')
source=("$pkgname::git+https://github.com/fabricecaruso/EmulationStation.git"
- 'share-dir.patch')
+ 'share-dir.patch'
+ 'emulationstation.desktop')
sha512sums=('SKIP'
- '72dcac3938c62ecda365bb50088658828d3876aa01d6a9ad21cb1b05da41f7defdee856ff353ab7b37d17a7f0b1e56d862e0da2da2b109e0dde3f8656a7848be')
+ '72dcac3938c62ecda365bb50088658828d3876aa01d6a9ad21cb1b05da41f7defdee856ff353ab7b37d17a7f0b1e56d862e0da2da2b109e0dde3f8656a7848be'
+ '00ddb6f2175290bf2cdb1fdee371c13fe67776b5222c9d79d3c1db1755d08d4cdae4f344d8131f97ef534d7e76dd2dc768f0ff49a41d0a8ee88fe44d4040e485')
if [ "$CARCH" = "armv6h" ]; then
depends+=('raspberrypi-firmware')
-else
-depends+=('libgl')
fi
pkgver() {
@@ -47,7 +47,9 @@ build() {
package() {
install -Dm755 "$srcdir/$pkgname/emulationstation" "$pkgdir/usr/bin/emulationstation"
- install -Dm644 "$srcdir/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/emulationstation/LICENSE"
- install -dm 755 "$pkgdir/usr/share/emulationstation"
+ install -Dm644 "$srcdir/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$pkgname/resources/window_icon_256.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/emulationstation.png"
+ install -Dm644 "$srcdir/emulationstation.desktop" "$pkgdir/usr/share/applications/emulationstation.desktop"
+ install -dm755 "$pkgdir/usr/share/emulationstation"
cp -r "$srcdir/$pkgname/resources" "$pkgdir/usr/share/emulationstation"
}
diff --git a/emulationstation.desktop b/emulationstation.desktop
new file mode 100644
index 000000000000..77f92e189e9b
--- /dev/null
+++ b/emulationstation.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=Emulation Station
+Categories=Game
+Comment=A flexible emulator front-end supporting keyboardless navigation and custom system themes.
+Exec=emulationstation
+Icon=emulationstation.png
+Terminal=false