summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrHermes2020-06-22 12:40:05 +0200
committerrHermes2020-06-22 12:40:05 +0200
commit7def361c2fa3ee7da6feb08b7a43e6c1999c069a (patch)
treef2a990ea6f707752f9b4656b6fef3b9329f16d87
parentd4577b9259819a492254b61fe9c9fedab0e87b80 (diff)
downloadaur-enchive.tar.gz
upgpkg: enchive 3.5-1
upstream release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91aa2a7bb780..5246784da796 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = enchive
pkgdesc = Utility for encrypting/decrypting single files with key pair
- pkgver = 3.4
+ pkgver = 3.5
pkgrel = 1
url = https://github.com/skeeto/enchive
arch = x86_64
arch = i686
license = custom:UNLICENSE
- source = enchive-3.4.tar.gz::https://github.com/skeeto/enchive/archive/3.4.tar.gz
- sha512sums = a8149a95723159b2ef6b929be91fc8d6b454886706eb701ba9fd1dfcfea59e1d22aea734517c08fc252681a914a1a028589789683540c13aacfa979c13313f17
+ source = https://github.com/skeeto/enchive/releases/download/3.5/enchive-3.5.tar.xz
+ source = https://github.com/skeeto/enchive/releases/download/3.5/enchive-3.5.tar.xz.sig
+ validpgpkeys = 5EEB8C8D5069C4E9B94AA852AFD1503A8C8FF42A
+ sha256sums = cb867961149116443a85d3a64ef5963e3c399bdd377b326669bb566a3453bd06
+ sha256sums = SKIP
pkgname = enchive
diff --git a/PKGBUILD b/PKGBUILD
index 16280305871a..fa5670f59a68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: C. N. Hsing <jlhs@users.noreply.github.com>
+# Maintainer: Teodor Spæren <teodor_spaeren@riseup.net>
+# Contributor: C. N. Hsing <jlhs@users.noreply.github.com>
pkgname=enchive
-pkgver=3.4
+pkgver=3.5
pkgrel=1
pkgdesc="Utility for encrypting/decrypting single files with key pair"
arch=('x86_64' 'i686')
url="https://github.com/skeeto/enchive"
license=('custom:UNLICENSE')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/skeeto/enchive/archive/$pkgver.tar.gz")
+source=("https://github.com/skeeto/${pkgname}/releases/download/${pkgver}/enchive-${pkgver}.tar.xz"{,.sig})
+sha256sums=('cb867961149116443a85d3a64ef5963e3c399bdd377b326669bb566a3453bd06'
+ 'SKIP')
+validpgpkeys=('5EEB8C8D5069C4E9B94AA852AFD1503A8C8FF42A') # Christopher Wellons <wellons@nullprogram.com>
build() {
- make -C $pkgname-$pkgver
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- cd $pkgname-$pkgver
- make PREFIX="$pkgdir"/usr install
-
- ## FIXUP: license, readme, and emacs intergation
- install -pDm644 UNLICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -pDm644 NEWS.md "$pkgdir"/usr/share/doc/$pkgname/NEWS.md
- install -pDm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
- install -pDm644 enchive-mode.el "$pkgdir"/usr/share/emacs/site-lisp/enchive-mode.el
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+ install -pDm644 UNLICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -pDm644 enchive-mode.el "${pkgdir}/usr/share/emacs/site-lisp/enchive-mode.el"
}
-
-sha512sums=('a8149a95723159b2ef6b929be91fc8d6b454886706eb701ba9fd1dfcfea59e1d22aea734517c08fc252681a914a1a028589789683540c13aacfa979c13313f17')