summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadly2016-04-29 10:13:39 +0200
committerTadly2016-04-29 10:13:39 +0200
commit07953708654f34f5f1dba1db0e8128c4adfbc88b (patch)
tree15423456e60ac08fe7bad746aff13a46ebf7770c
parent9df6e0d10178dacd44bf1595701ec430188cec61 (diff)
downloadaur-07953708654f34f5f1dba1db0e8128c4adfbc88b.tar.gz
update to 5.2.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD38
-rw-r--r--enpass-bin.install41
3 files changed, 57 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9172ba0f74e9..fb522ea2cb08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Mar 4 13:19:03 UTC 2016
+# Fri Apr 29 08:12:06 UTC 2016
pkgbase = enpass-bin
pkgdesc = A multiplatform password manager
- pkgver = 5.0.5
+ pkgver = 5.2.0
pkgrel = 1
url = http://enpass.io/
install = enpass-bin.install
@@ -11,7 +11,10 @@ pkgbase = enpass-bin
license = custom
depends = libxss
depends = lsof
- source = http://repo.sinew.in/pool/main/e/enpass/enpass_5.0.5_.deb
+ source_i686 = http://repo.sinew.in/pool/main/e/enpass/enpass_5.2.0_i386.deb
+ sha256sums_i686 = 14695d8549d7ca7ff0612d687b49e4ad6e8a41863be94e8cacabc8c21f6069c5
+ source_x86_64 = http://repo.sinew.in/pool/main/e/enpass/enpass_5.2.0.1_amd64.deb
+ sha256sums_x86_64 = f6ca52edf0e6c0a075e93f823b9395a0e8c5a3217231d139b8cd40c2ca5e71f6
pkgname = enpass-bin
diff --git a/PKGBUILD b/PKGBUILD
index 97ae8c0af027..1bfd00e004ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
pkgname=enpass-bin
_pkgname=enpass
-pkgver=5.0.5
+pkgver=5.2.0
+_pkgver_x86_x64=5.2.0.1
+_pkgver_i686=5.2.0
pkgrel=1
pkgdesc="A multiplatform password manager"
arch=('i686' 'x86_64')
@@ -8,26 +10,18 @@ url="http://enpass.io/"
license=('custom')
depends=('libxss' 'lsof')
install=enpass-bin.install
-case $CARCH in
- 'x86_64')
- _arch='amd64'
- sha256sums=(
- 'cd413cb9170fc2d777d30a68103c9758059c4ce00beebd513b0773eadf2f9acc'
- )
- ;;
- 'i686')
- _arch='i386'
- sha256sums=(
- 'b196897e7dcb7f183bdcf82d0a03f2a97746efb6c51798db03a9587f21fec6db'
- )
- ;;
-esac
-
-source=(http://repo.sinew.in/pool/main/e/enpass/${_pkgname}_${pkgver}_${_arch}.deb)
+source_x86_64=("http://repo.sinew.in/pool/main/e/enpass/${_pkgname}_${_pkgver_x86_x64}_amd64.deb")
+source_i686=("http://repo.sinew.in/pool/main/e/enpass/${_pkgname}_${_pkgver_i686}_i386.deb")
+sha256sums_x86_64=(
+ 'f6ca52edf0e6c0a075e93f823b9395a0e8c5a3217231d139b8cd40c2ca5e71f6'
+)
+sha256sums_i686=(
+ '14695d8549d7ca7ff0612d687b49e4ad6e8a41863be94e8cacabc8c21f6069c5'
+)
package() {
# Extract data
- tar xfz ${srcdir}/data.tar.gz -C ${pkgdir}/
+ tar xfz ${srcdir}/data.tar.gz -C ${pkgdir}
# Remove unnecessary files which are included in the .deb
find ${pkgdir} -name ".DS_Store" -delete
@@ -38,7 +32,13 @@ package() {
chmod 755 ${pkgdir}/opt/
find ${pkgdir}/usr/ -type d -exec chmod 755 {} \;
- # Symlink "runenpass.sh" to "/usr/bin" so it is accessible via terminal
+ # Symlink libssl and libcrypto
+ cd ${pkgdir}/opt/Enpass/lib/
+ ln -s ./libssl.so.1.0.0 ./libssl.so
+ ln -s ./libcrypto.so.1.0.0 ./libcrypto.so
+ cd -
+
+ # Symlink "runenpass.sh" to "/usr/bin" so it is accessible via cli
mkdir -p ${pkgdir}/usr/bin
ln -s /opt/Enpass/bin/runenpass.sh ${pkgdir}/usr/bin/enpass
}
diff --git a/enpass-bin.install b/enpass-bin.install
index b5d2286c9f77..496b33989ce3 100644
--- a/enpass-bin.install
+++ b/enpass-bin.install
@@ -1,12 +1,35 @@
-post_install() {
- update-desktop-database -q
- gtk-update-icon-cache -f /usr/share/icons/hicolor
-}
-
post_upgrade() {
- post_install
-}
+cat << EOF
+
+ If you encounter scaling issues try:
+
+ export QT_AUTO_SCREEN_SCALE_FACTOR=0
+
+ before running enpass.
+ If this worked, you have 3 options:
+
+ 1. Add the above line to your ".bashrc"
+
+ 2. Add the above line to
+ /opt/Enpass/bin/runenpass.sh
+
+ BEFORE the "exec" command.
+ Keep in mind that changes to runenpass.sh
+ will be overwritten upon the next update.
+
+ 3. Create a copy of:
+
+ /usr/share/applications/enpass.desktop
+
+ to
+
+ ~/.local/share/applications/enpass.desktop
+
+ and replace the "Exec=" line with:
+
+ Exec=env QT_AUTO_SCREEN_SCALE_FACTOR=0 /opt/Enpass/bin/runenpass.sh %U
-post_remove() {
- post_install
+ This will NOT fix scaling if you run enpass from
+ your commandline!
+EOF
}