summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorn0vember2021-11-21 15:58:27 +0100
committern0vember2021-11-21 15:58:27 +0100
commitaaba045bf7424d0aa7a110f896e4ac2a004753b6 (patch)
treee30285d1544896bc8c854b985f84523fd91c11a1
parent789187573f97d9ea2fb5b8af5efdd2a468bb4361 (diff)
downloadaur-envconsul-git.tar.gz
update Makefile to have all cleaning in one line
MAke fails if a rm command does not match any file. So if first rm fail, second rm is not issued and cleaning is not done. Having all removals in one line ensures cleaning is done whatever the state was
-rw-r--r--Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 0c96d3d8c708..2d39bb71b518 100644
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,4 @@ package:
clean:
@test -d pkg && chmod -R u+w pkg
@test -d src && chmod -R u+w src
- @rm -vrf pkg
- @rm -vrf src
- @rm -vr *.tar.gz
- @rm -vr *.tar.xz
+ @rm -vrf pkg src *.tar.gz *.tar.xz *.tar.zst