summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2017-05-19 10:22:58 +0900
committerQue Quotion2017-05-19 10:22:58 +0900
commitdd857968b00c87b262fed5ce20dc00ab0831d07e (patch)
tree83bf34543758f92079c6515979b8c2827e3b5cd1
parentca24717e1a1140243d98b8305a3b5961e9357c2c (diff)
downloadaur-dd857968b00c87b262fed5ce20dc00ab0831d07e.tar.gz
Fine tuning; preparing for future maintenance
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4209be7196c1..79ec89de5336 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Thu May 18 16:06:26 UTC 2017
+# Fri May 19 01:22:30 UTC 2017
pkgbase = epiphany-pantheon-bzr
pkgdesc = A GNOME web browser based on the WebKit rendering engine, with ElementaryOS patchset
pkgver = 3.18.5.r11
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnome.org/projects/epiphany/
arch = i686
arch = x86_64
- groups = gnome
+ groups = pantheon-unstable
+ groups = pantheon-qq
license = GPL
makedepends = intltool
makedepends = itstool
diff --git a/PKGBUILD b/PKGBUILD
index e2946295a224..9bcd8b904614 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,10 @@
_pkgname=epiphany
pkgname=$_pkgname-pantheon-bzr
+ephyver=3.18.5
+ubunturel=xenial
pkgver=3.18.5.r11
-pkgrel=1
+pkgrel=2
pkgdesc="A GNOME web browser based on the WebKit rendering engine, with ElementaryOS patchset"
url="http://www.gnome.org/projects/epiphany/"
arch=('i686' 'x86_64')
@@ -12,12 +14,12 @@ license=('GPL')
depends=(webkit2gtk gcr gnome-desktop)
makedepends=(intltool itstool docbook-xml startup-notification lsb-release
gobject-introspection yelp-tools autoconf-archive appstream-glib bzr git)
-groups=(gnome)
+groups=(pantheon-unstable pantheon-qq)
replaces=(epiphany)
provides=(epiphany)
conflicts=(epiphany)
-source=("https://git.gnome.org/browse/epiphany/snapshot/epiphany-3.18.5.tar.xz"
- "bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-xenial"
+source=("https://git.gnome.org/browse/$_pkgname/snapshot/$_pkgname-$ephyver.tar.xz"
+ "bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-$ubunturel"
"git+https://git.gnome.org/browse/libgd"
"git://git.gnome.org/gvdb"
"pluginsdir.diff"
@@ -30,21 +32,21 @@ sha256sums=('8ada9f9af99902539d69fcba32607f5d8f80921d0475293088bc2f191499a8ef'
'f569c4a01e4fe9c207b0ed22f6fbd4d25ac29868c59f585d658aa478695f1617')
pkgver() {
- cd os-patch-epiphany-browser-xenial
+ cd "os-patch-epiphany-browser-$ubunturel"
- echo "3.18.5.r$(bzr revno)"
+ echo "$ephyver.r$(bzr revno)"
}
prepare() {
- cd $_pkgname-3.18.5
+ cd $_pkgname-$ephyver
# Apply Patches
- for i in $(grep -v '#' "$srcdir/os-patch-epiphany-browser-xenial/debian/patches/series" | sort); do
+ for i in $(grep -v '#' "$srcdir/os-patch-epiphany-browser-$ubunturel/debian/patches/series" | sort); do
[[ "${i}" =~ ^# || -z "${i}" ]] || \
[[ "${i}" == 99_toolbar_add_bookmark_button.patch ]] || \
[[ "${i}" == 99_tabs_double_click_opens_new_tab.patch ]] && continue
msg2 "Applying $i ..."
- patch -Np1 < "$srcdir/os-patch-epiphany-browser-xenial/debian/patches/$i"
+ patch -Np1 < "$srcdir/os-patch-epiphany-browser-$ubunturel/debian/patches/$i"
done
msg2 "Plugins Directory"
@@ -60,7 +62,7 @@ prepare() {
}
build() {
- cd $_pkgname-3.18.5
+ cd "$_pkgname-$ephyver"
./autogen.sh --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --libexecdir=/usr/lib/$pkgname --enable-compile-warnings=yes
@@ -71,6 +73,6 @@ build() {
}
package() {
- cd $_pkgname-3.18.5
+ cd "$_pkgname-$ephyver"
make DESTDIR="$pkgdir" install
}