summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Thomas2016-06-11 09:29:45 +0100
committerJames Thomas2016-06-11 09:29:45 +0100
commit0893e2c3e2d5ca00cd5528621de5b833e7cb40d7 (patch)
tree83adee80644abab7488b0e8fa37225394db5b769
parent4bedc1168dfe88416d3055be00117b836f3e0b25 (diff)
downloadaur-0893e2c3e2d5ca00cd5528621de5b833e7cb40d7.tar.gz
further tweaked PKGBUILD and added a man page
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
-rw-r--r--epubcheck.1131
3 files changed, 152 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec466d88e1d9..f10b4ddd77bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = epubcheck
- pkgdesc = A tool to validate IDPF Epub files.
+ pkgdesc = A tool to validate epub files.
pkgver = 4.0.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/IDPF/epubcheck
arch = any
license = BSD
depends = java-environment
+ source = epubcheck.1
source = https://github.com/IDPF/epubcheck/releases/download/v4.0.1/epubcheck-4.0.1.zip
+ md5sums = 28b6a51045dab25a156ffc2fc8a4f20d
md5sums = e5834be417b8e9ddcdb1498929ecd41e
pkgname = epubcheck
diff --git a/PKGBUILD b/PKGBUILD
index 27bee64df6c4..8a308e460778 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Contributor: James Thomas <dairy_water at yahoo dot co dot uk>
pkgname=epubcheck
pkgver=4.0.1
-pkgrel=4
-pkgdesc="A tool to validate IDPF Epub files."
+pkgrel=5
+pkgdesc="A tool to validate epub files."
arch=('any')
url="https://github.com/IDPF/epubcheck"
license=('BSD')
depends=('java-environment')
-source=(https://github.com/IDPF/epubcheck/releases/download/v${pkgver}/${pkgname}-${pkgver}.zip)
-md5sums=('e5834be417b8e9ddcdb1498929ecd41e')
+source=("epubcheck.1" "https://github.com/IDPF/epubcheck/releases/download/v${pkgver}/${pkgname}-${pkgver}.zip")
+md5sums=('28b6a51045dab25a156ffc2fc8a4f20d'
+ 'e5834be417b8e9ddcdb1498929ecd41e')
package() {
- mkdir -p $pkgdir/usr/share/java/${pkgname}
- install -D -m644 $srcdir/${pkgname}-${pkgver}/epubcheck.jar $pkgdir/usr/share/java/${pkgname}
- mkdir -p $pkgdir/usr/share/java/${pkgname}/lib
- install -D -m644 $srcdir/${pkgname}-${pkgver}/lib/*.jar $pkgdir/usr/share/java/${pkgname}/lib
- mkdir -p $pkgdir/usr/share/docs/${pkgname}
- install -D -m644 $srcdir/${pkgname}-${pkgver}/*.txt $pkgdir/usr/share/docs/${pkgname}
- mkdir -p $pkgdir/usr/share/licenses/${pkgname}
- install -D -m644 $srcdir/${pkgname}-${pkgver}/licenses/BSD-3-Clause.txt $pkgdir/usr/share/licenses/${pkgname}/LICENSE
- mkdir -p $pkgdir/usr/bin
+ install -d "$pkgdir/usr/share"/{java,docs,licenses}/"${pkgname}" "$pkgdir/usr/share/java/${pkgname}/lib"
+ install -m644 "$srcdir/${pkgname}-${pkgver}/epubcheck.jar" "$pkgdir/usr/share/java/${pkgname}/epubcheck.jar"
+ install -m644 "$srcdir/${pkgname}-${pkgver}/lib"/*.jar "$pkgdir/usr/share/java/${pkgname}/lib"
+ install -m644 "$srcdir/${pkgname}-${pkgver}"/*.txt "$pkgdir/usr/share/docs/${pkgname}"
+ install -m644 "$srcdir/${pkgname}-${pkgver}/licenses/BSD-3-Clause.txt" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
- cat >> $pkgdir/usr/bin/${pkgname} << EOF
+ install -D -m644 "$srcdir/epubcheck.1" "$pkgdir/usr/share/man/man1/epubcheck.1"
+
+ mkdir -p "$pkgdir/usr/bin"
+
+ cat >> "$pkgdir/usr/bin/${pkgname}" << EOF
#!/bin/bash
exec /usr/bin/java -jar '/usr/share/java/epubcheck/epubcheck.jar' "\$@"
EOF
- chmod +x $pkgdir/usr/bin/${pkgname}
+ chmod +x "$pkgdir/usr/bin/${pkgname}"
}
+
diff --git a/epubcheck.1 b/epubcheck.1
new file mode 100644
index 000000000000..f9fb22f0f06f
--- /dev/null
+++ b/epubcheck.1
@@ -0,0 +1,131 @@
+.\" Enhanced version of file generated by help2man 1.47.3
+.TH EPUBCHECK 1 "2016-06-01" "epubcheck 4.0.1" "Epubcheck Manual"
+.SH NAME
+\fBepubcheck\fR - a tool to validate EPUB files
+.SH SYNOPSIS
+\fBepubcheck\fR [ \fB\-\-profile\fR \fIprofile\fR ] [ \fB\-\-mode\fR \fImode\fR ] [ \fIoptions\fR ] [ file ]
+.SH DESCRIPTION
+\fBepubcheck\fR is a tool to validate EPUB 2 and EPUB 3 files. It can detect many types of errors in EPUB. OCF container structure, OPF and OPS mark-up, and internal reference
+consistency are checked.
+.PP
+\fBepubcheck\fR can be run as a standalone command-line tool or used as a Java library.
+.SH OPTIONS
+.BR
+.SS "General options"
+.BR
+.TP
+\fB\-s\fR, \fB\-\-save\fR
+Saves the EPUB created from the validation check of an expanded EPUB archive
+.TP
+\fB\-o\fR, \fB\-\-out\fR \fIfile\fR
+Output an assessment XML document file (use \- to output to console)
+.TP
+\fB\-x\fR, \fB\-\-xmp\fR \fIfile\FR
+Output an assessment XMP document file (use \- to output to console)
+.TP
+\fB\-j\fR, \fB\-\-json\fR \fIfile\fR
+Output an assessment JSON document file (use \- to output to console)
+.TP
+\fB\-m\fR, \fB\-\-mode\fR \fImode\fR
+Specify the mode (required for validating non-EPUB files)
+.TP
+\fB\-p\fR, \fB\-\-profile\fR \fIprofile\fR
+Specify the profile to validate against
+.TP
+\fB\-\-failonwarnings\fR
+By default, the tool returns 1 if errors are found in the file or 0 if no errors are found.
+Using \fB\-\-failonwarnings\fR will cause the process to exit with a status of 1 if either warnings or errors are present and 0 only when there are no errors or warnings.
+.TP
+\fB\-q\fR, \fB\-\-quiet\fR
+No message on console, except errors, only in the output
+.TP
+\fB\-f\fR, \fB\-\-fatal\fR
+Include only fatal errors in the output
+.TP
+\fB\-e\fR, \fB\-\-error\fR
+Include only error and fatal severity messages in ouput
+.TP
+\fB\-w\fR, \fB\-\-warn\fR
+Include fatal, error, and warn severity messages in output
+.TP
+\fB\-u\fR, \fB\-\-usage\fR
+Include ePub feature usage information in output (default is OFF); if enabled, usage information will
+always be included in the output file
+.TP
+\fB\-l\fR, \fB\-\-listChecks\fR \fIfile\fR
+List message ids and severity levels to the custom message file named \fIfile\fR or the console
+.TP
+\fB\-c\fR, \fB\-\-customMessages\fR \fIfile\fR
+Override message severity levels as defined in the custom message file named \fIfile\fR
+.TP
+\fB\-h\fR, \fB\-?\fR or \fB\-\-help\fR
+Displays help message
+.BR
+.SS "Modes"
+.BR
+.PP
+If checking a non\-epub file, the type of the file must be specified using \fB\-\-mode\fR and the epub version of the file must
+be specified using \fB\-v\fR. The default version is 3.0.
+.TP
+\fB\-\-mode\fR \fIopf\fR \fB\-v\fR \fI2.0\fR
+For single OPF file validation (EPUB 2)
+.TP
+\fB\-\-mode\fR \fIopf\fR \fB\-v\fR \fI3.0\fR
+For single OPF file validation (EPUB 3)
+.TP
+\fB\-\-mode\fR \fIxhtml\fR \fB\-v\fR \fI2.0\fR
+For single XHTML file validation (EPUB 2)
+.TP
+\fB\-\-mode\fR \fIxhtml\fR \fB\-v\fR \fI3.0\fR
+For single XHTML file validation (EPUB 3)
+.TP
+\fB\-\-mode\fR \fIsvg\fR \fB\-v\fR \fI2.0\fR
+For single SVG file validation (EPUB 2)
+.TP
+\fB\-\-mode\fR \fIsvg\fR \fB\-v\fR \fI3.0\fR
+For single SVG file validation (EPUB 3)
+.TP
+\fB\-\-mode\fR \fInav\fR \fB\-v\fR \fI3.0\fR
+For single 'Navigation Document' validation
+.TP
+\fB\-\-mode\fR \fImo\fR \fB\-v\fR \fI3.0\fR
+For single 'Media Overlays' validation
+.TP
+\fB\-\-mode\fR \fIexp\fR
+For validating expanded EPUB archives
+.BR
+.SS "Validation profiles"
+.BR
+.PP
+To specify a validation profile (to run checks against a specific EPUB 3 profile
+or extension specification), use the \fB\-\-profile\fR option.
+.TP
+\fB\-\-profile\fR \fIdefault\fR
+The default validation profile
+.TP
+\fB\-\-profile\fR \fIdict\fR
+Validates against the EPUB Dictionaries and Glossaries specification
+.TP
+\fB\-\-profile\fR \fIedupub\fR
+Validates against the EDUPUB Profile
+.TP
+\fB\-\-profile\fR \fIidx\fR
+Validates against the EPUB Indexes specification
+.TP
+\fB\-\-profile\fR \fIpreview\fR
+Validates against the EPUB Previews specification
+.SH EXAMPLES
+.TP
+\fBepubcheck\fR \fIfilename\fR
+Perfom a simple validation check on an EPUB file
+.TP
+\fBepubcheck \-\-mode\fR \fIexp filename\fR
+Perform a vaidation check on an expanded EPUB archive (add \fB\-\-save\fR to save the built epub)
+.TP
+\fBepubcheck \-\-mode\fR \fIxhtml\fR \fB\-v\fR \fI3.0 filename\fR
+Perform a validation check on a single xhtml file from an EPUB 3
+.SH AUTHORS
+.PP
+\fBepubcheck\fR development can be followed at: \fIhttps://github.com/IDPF/epubcheck\fR
+.PP
+This man page was compiled from various sources by James Thomas \fI<dairy_water at yahoo dot co dot uk>\fR