summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxDShot2024-07-02 13:10:02 +0300
committerxDShot2024-07-02 13:10:02 +0300
commit9be0fe964ef1835f48f4bbe3fe46cb96583a73e3 (patch)
tree2e974127dd7efd550fd2d12084e10cf71115761f
parent94d6817e8f4e4580b14298464f09e71ab65de8fc (diff)
downloadaur-ericw-tools-git.tar.gz
lightpreview added
fixed dependencies
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
3 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 496c28ae40f8..1f5fc197f905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ericw-tools-git
pkgdesc = Quake/Hexen 2 Map compiling tools
- pkgver = 0.18.2.rc1.r2115.g9f7ba657
+ pkgver = 2.0.0.alpha8.r9.g04604b18
pkgrel = 1
url = https://ericwa.github.io/ericw-tools
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = ericw-tools-git
makedepends = git
makedepends = python-sphinx
makedepends = python-sphinx-furo
+ makedepends = python-sphinx-autobuild
depends = embree3
depends = groff
depends = tbb
@@ -19,8 +20,6 @@ pkgbase = ericw-tools-git
source = json::git+https://github.com/ArthurSonzogni/nlohmann_json_cmake_fetchcontent.git
source = nanobench::git+https://github.com/martinus/nanobench
source = pareto::git+https://github.com/alandefreitas/pareto.git
- source = doctest::git+https://github.com/doctest/doctest
- sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 74f6512acb9d..c0c5a30736b5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,6 @@ pkg/*
ericw-tools/*
fmt/*
googletest/*
+pareto/*
+nanobench/*
json/*
diff --git a/PKGBUILD b/PKGBUILD
index 90509f1dba94..79e65299d34f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_pkgname=ericw-tools
pkgname=${_pkgname}-git
-pkgver=0.18.2.rc1.r2115.g9f7ba657
+pkgver=2.0.0.alpha8.r9.g04604b18
pkgrel=1
pkgdesc="Quake/Hexen 2 Map compiling tools"
arch=('x86_64')
@@ -8,7 +8,7 @@ url="https://ericwa.github.io/ericw-tools"
_giturl="https://github.com/ericwa/ericw-tools"
license=('GPL3')
depends=('embree3' 'groff' 'tbb')
-makedepends=('cmake' 'git' 'python-sphinx' 'python-sphinx-furo')
+makedepends=('cmake' 'git' 'python-sphinx' 'python-sphinx-furo' 'python-sphinx-autobuild')
provides=(${_pkgname})
conflicts=(${_pkgname})
source=("${_pkgname}::git+${_giturl}.git#branch=brushbsp"
@@ -16,13 +16,11 @@ source=("${_pkgname}::git+${_giturl}.git#branch=brushbsp"
"json::git+https://github.com/ArthurSonzogni/nlohmann_json_cmake_fetchcontent.git"
"nanobench::git+https://github.com/martinus/nanobench"
"pareto::git+https://github.com/alandefreitas/pareto.git"
- "doctest::git+https://github.com/doctest/doctest"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -36,7 +34,6 @@ prepare() {
git config submodule.3rdparty/json.url ../json
git config submodule.3rdparty/nanobench.url ../nanobench
git config submodule.3rdparty/pareto.url ../pareto
- git config submodule.3rdparty/doctest.url ../doctest
git submodule update
}
@@ -48,7 +45,7 @@ build() {
}
package() {
- _files=(qbsp vis light bspinfo bsputil)
+ _files=(qbsp vis light bspinfo bsputil lightpreview)
for _i in "${_files[@]}"
do
install -Dm755 build/${_i}/${_i} "$pkgdir"/usr/bin/${_i}