summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2024-04-13 22:54:24 +0300
committerAdrian Perez de Castro2024-04-13 22:54:24 +0300
commit2dda23ca77e9f56f26d2e10db9834429129998a1 (patch)
tree469fcc00fb43fbd772a315b496c44cfe2f2a741a
parent19534d6ad6d96c0a2e84c09b1c9b0de2d8d88c0b (diff)
downloadaur-es.tar.gz
Bump to version 0.9.2
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD18
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8286ce0c0ce8..c620ce3502c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = es
pkgdesc = Extensible Shell derived from Plan9 rc
- pkgver = 0.9.1
+ pkgver = 0.9.2
pkgrel = 1
url = http://wryun.github.io/es-shell/
install = es.install
@@ -9,8 +9,7 @@ pkgbase = es
makedepends = bison
depends = readline
depends = termcap
- source = https://github.com/wryun/es-shell/releases/download/v0.9.1/es-0.9.1.tar.gz
- sha512sums = 4dfa2096e14977437e5dea3ac89e65dc08b5abbb0433af711a1759d5f719f82b24fdcc85ff764526aaae627998da4022504bb21fe96adeb3e434f29356f39593
+ source = https://github.com/wryun/es-shell/releases/download/v0.9.2/es-0.9.2.tar.gz
+ b2sums = 7d317e046f7211eb4ce3c79573a5f6809e9e5928f63b3c3a08fe07c27af5cf50f2ecd30f7406a787d8a228b263e18bbc35d9025f7b94223b5b2b7d2f32eb730e
pkgname = es
-
diff --git a/.gitignore b/.gitignore
index 45cccfdb444d..0066b450fb8c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
-/src/
-/pkg/
-/*.tar
-/*.tar.*
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
+!/es.install
diff --git a/PKGBUILD b/PKGBUILD
index b4380d255261..bf414944f142 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
# Maintainer: Adrián Pérez de Castro
pkgdesc='Extensible Shell derived from Plan9 rc'
pkgname=es
-pkgver=0.9.1
+pkgver=0.9.2
pkgrel=1
arch=(x86_64)
-url='http://wryun.github.io/es-shell/'
+url=http://wryun.github.io/es-shell/
depends=(readline termcap)
makedepends=(bison)
license=('custom:Public Domain')
install=es.install
source=("https://github.com/wryun/es-shell/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('4dfa2096e14977437e5dea3ac89e65dc08b5abbb0433af711a1759d5f719f82b24fdcc85ff764526aaae627998da4022504bb21fe96adeb3e434f29356f39593')
+b2sums=('7d317e046f7211eb4ce3c79573a5f6809e9e5928f63b3c3a08fe07c27af5cf50f2ecd30f7406a787d8a228b263e18bbc35d9025f7b94223b5b2b7d2f32eb730e')
build () {
- ./configure --prefix=/usr --with-readline
+ CFLAGS="-Wno-unused-const-variable" ./configure --prefix=/usr --with-readline
make
}
package () {
- # The included Makefile does NOT honor DESTDIR (or anything like it)
- install -D -m755 es "${pkgdir}/usr/bin/es"
- install -D -m644 doc/es.1 "${pkgdir}/usr/share/man/man1/es.1"
+ make DESTDIR="$pkgdir" install
# Documentation and examples.
- install -D -m644 README "${pkgdir}/usr/share/licenses/${pkgname}/README"
+ install -D -m644 README.md \
+ "${pkgdir}/usr/share/licenses/${pkgname}/README.md"
install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
doc/ERRATA doc/usenix-w93.ps doc/es-list.gz
install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}/examples" \
- examples/*
+ examples/*.*
+ cp -r examples/friedman "${pkgdir}/usr/share/doc/${pkgname}/examples"
}
check () {