summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Pietri2015-07-28 20:27:29 +0200
committerAntoine Pietri2015-07-28 20:27:29 +0200
commita14bb85268aa5c3e941003972e17d974ad46c004 (patch)
treee598024297684e50e36b34f9e47faa6fba3441d1
downloadaur-esotope-bfc-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7201ac96a945
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = esotope-bfc-git
+ pkgdesc = esotope-bfc, the world's most optimizing Brainfuck-to-something compiler
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://code.google.com/p/esotope-bfc/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = mercurial
+ makedepends = python2-setuptools
+ depends = python2
+ provides = esotope-bfc
+ source = hg+https://bitbucket.org/serialk/esotope-bfc
+ sha512sums = SKIP
+
+pkgname = esotope-bfc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..580d25a23bf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=esotope-bfc-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="esotope-bfc, the world's most optimizing Brainfuck-to-something compiler"
+arch=('i686' 'x86_64')
+url="https://code.google.com/p/esotope-bfc/"
+license=('MIT')
+provides=('esotope-bfc')
+depends=('python2')
+makedepends=('mercurial' 'python2-setuptools')
+source=("hg+https://bitbucket.org/serialk/esotope-bfc")
+sha512sums=(SKIP)
+
+package() {
+ cd esotope-bfc
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}