summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kojevnikov2015-09-15 17:03:58 +1000
committerAndrey Kojevnikov2015-09-15 17:03:58 +1000
commit42a0e8d9b240eb5cecc95b19e7c4bfc270d3b1fa (patch)
tree230bc159ed4d535addb527b4a80c8adefb23efce
parent7e839962bbe69d1375621dd7f18a54b9367c9fc6 (diff)
downloadaur-42a0e8d9b240eb5cecc95b19e7c4bfc270d3b1fa.tar.gz
v2.2.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
-rw-r--r--etcd.conf133
-rw-r--r--etcd.install13
4 files changed, 124 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3feae29d0cb..7acf72fead12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = etcd
pkgdesc = A highly-available key value store for shared configuration and service discovery.
- pkgver = 2.1.2
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/coreos/etcd
install = etcd.install
@@ -8,16 +8,13 @@ pkgbase = etcd
arch = i686
license = Apache
makedepends = go
- provides = etcdctl
- conflicts = etcdctl
- replaces = etcdctl
backup = etc/conf.d/etcd
- source = etcd-2.1.2.tar.gz::https://github.com/coreos/etcd/archive/v2.1.2.tar.gz
+ source = etcd-2.2.0.tar.gz::https://github.com/coreos/etcd/archive/v2.2.0.tar.gz
source = etcd.service
source = etcd.conf
- md5sums = 6fc5facbb0e1d43422e35935b90fb5c8
+ md5sums = cc45035ba15771a4fa5cc3645ff8ffd8
md5sums = dabe32f9e766b935c075b832672b2a79
- md5sums = a6043503d766097eb9fb0d0e142b96f3
+ md5sums = bd315606b36e519c578db34722b57622
pkgname = etcd
diff --git a/PKGBUILD b/PKGBUILD
index 173285262c09..ef514bd8511c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: codekoala <codekoala at gmail dot com>
pkgname=etcd
-pkgver=2.1.2
+pkgver=2.2.0
pkgrel=1
pkgdesc='A highly-available key value store for shared configuration and service discovery.'
arch=('x86_64' 'i686')
@@ -11,16 +11,13 @@ url='https://github.com/coreos/etcd'
license=('Apache')
makedepends=('go')
backup=('etc/conf.d/etcd')
-provides=('etcdctl')
-replaces=('etcdctl')
-conflicts=('etcdctl')
install="${pkgname}.install"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/coreos/${pkgname}/archive/v${pkgver}.tar.gz"
"${pkgname}.service"
"${pkgname}.conf")
-md5sums=('6fc5facbb0e1d43422e35935b90fb5c8'
+md5sums=('cc45035ba15771a4fa5cc3645ff8ffd8'
'dabe32f9e766b935c075b832672b2a79'
- 'a6043503d766097eb9fb0d0e142b96f3')
+ 'bd315606b36e519c578db34722b57622')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
diff --git a/etcd.conf b/etcd.conf
index 1eb860ce1dd4..023129b0e075 100644
--- a/etcd.conf
+++ b/etcd.conf
@@ -1,172 +1,249 @@
# Human_readable name for this member.
+#
# default: "default"
#
# ETCD_NAME="default"
-#
# Path to the data directory.
+#
# default: "${name}.etcd"
# distribution default: "/var/lib/etcd"
#
# ETCD_DATA_DIR="/var/lib/etcd"
+
+# Path to the dedicated wal directory.
+# If this flag is set, etcd will write the WAL files
+# to the walDir rather than the dataDir.
+#
+# default: ""
#
+# ETCD_WAL_DIR=""
# Number of committed transactions to trigger a snapshot to disk.
-# default: "10000"
#
-# ETCD_SNAPSHOT_COUNT="10000"
+# default: 10000
#
+# ETCD_SNAPSHOT_COUNT=10000
# Time (in milliseconds) of a heartbeat interval.
-# default: "100"
#
-# ETCD_HEARTBEAT_INTERVAL="100"
+# default: 100
#
+# ETCD_HEARTBEAT_INTERVAL=100
# Time (in milliseconds) for an election to timeout.
-# default: "1000"
#
-# ETCD_ELECTION_TIMEOUT="1000"
+# default: 1000
#
+# ETCD_ELECTION_TIMEOUT=1000
# List of URLs to listen on for peer traffic.
+#
# default: "http://localhost:2380,http://localhost:7001"
#
# ETCD_LISTEN_PEER_URLS="http://localhost:2380,http://localhost:7001"
-#
# List of URLs to listen on for client traffic.
+#
# default: "http://localhost:2379,http://localhost:4001"
#
# ETCD_LISTEN_CLIENT_URLS="http://localhost:2379,http://localhost:4001"
-#
# Maximum number of snapshot files to retain (0 is unlimited)
+#
# default: 5
#
# ETCD_MAX_SNAPSHOTS=5
-#
# Maximum number of wal files to retain (0 is unlimited)
+#
# default: 5
#
# ETCD_MAX_WALS=5
-#
# Comma_separated white list of origins for CORS (cross_origin resource sharing).
+#
# default: none
#
# ETCD_CORS=
-#
# List of this member's peer URLs to advertise to the rest of the cluster.
# These addresses are used for communicating etcd data around the cluster.
# At least one must be routable to all cluster members.
+#
# default: "http://localhost:2380,http://localhost:7001"
#
# ETCD_INITIAL_ADVERTISE_PEER_URLS="http://localhost:2380,http://localhost:7001"
-#
# Initial cluster configuration for bootstrapping.
+#
# default: "default=http://localhost:2380,default=http://localhost:7001"
# distribution default: "default=http://localhost:2380,default=http://localhost:7001"
#
# ETCD_INITIAL_CLUSTER="default=http://localhost:2380,default=http://localhost:7001"
-#
# Initial cluster state ("new" or "existing").
# Set to new for all members present during initial static or DNS bootstrapping.
# If this option is set to existing, etcd will attempt to join the existing cluster.
# If the wrong value is set, etcd will attempt to start but fail safely.
+#
# default: "new"
#
# ETCD_INITIAL_CLUSTER_STATE="new"
-#
# Initial cluster token for the etcd cluster during bootstrap.
+#
# default: "etcd_cluster"
#
# ETCD_INITIAL_CLUSTER_TOKEN="etcd_cluster"
-#
# List of this member's client URLs to advertise to the rest of the cluster.
+#
# default: "http://localhost:2379,http://localhost:4001"
#
# ETCD_ADVERTISE_CLIENT_URLS="http://localhost:2379,http://localhost:4001"
-#
# Discovery URL used to bootstrap the cluster.
+#
# default: none
#
# ETCD_DISCOVERY=
-#
# DNS srv domain used to bootstrap the cluster.
+#
# default: none
#
# ETCD_DISCOVERY_SRV=
-#
# Expected behavior ("exit" or "proxy") when discovery services fails.
+#
# default: "proxy"
#
# ETCD_DISCOVERY_FALLBACK="proxy"
-#
# HTTP proxy to use for traffic to discovery service.
+#
# default: none
#
# ETCD_DISCOVERY_PROXY=
-#
# Proxy mode setting ("off", "readonly" or "on").
+#
# default: "off"
#
# ETCD_PROXY="off"
+
+# Time (in milliseconds) an endpoint will be held
+# in a failed state before being reconsidered for proxied requests.
+#
+# default: 5000
+#
+# ETCD_PROXY_FAILURE_WAIT=5000
+
+# Time (in milliseconds) of the endpoints refresh interval.
+#
+# default: 30000
+#
+# ETCD_PROXY_REFRESH_INTERVAL=30000
+
+# Time (in milliseconds) for a dial to timeout or 0 to disable the timeout.
+#
+# default: 1000
+#
+# ETCD_PROXY_DIAL_TIMEOUT=1000
+
+# Time (in milliseconds) for a write to timeout or 0 to disable the timeout.
+#
+# default: 5000
#
+# ETCD_PROXY_WRITE_TIMEOUT=5000
+
+# Time (in milliseconds) for a read to timeout or 0 to disable the timeout.
+# Don't change this value if you use watches because they are using long polling requests.
+#
+# default: 0
+#
+# ETCD_PROXY_READ_TIMEOUT=0
# Path to the client server TLS CA file.
+#
# default: none
#
# ETCD_CA_FILE=
-#
# Path to the client server TLS cert file.
+#
# default: none
#
# ETCD_CERT_FILE=
-#
# Path to the client server TLS key file.
+#
# default: none
#
# ETCD_KEY_FILE=
+
+# Enable client cert authentication.
+#
+# default: false
#
+# ETCD_CLIENT_CERT_AUTH=false
-# Path to the peer server TLS CA file.
+# Path to the client server TLS trusted CA key file.
+#
# default: none
#
-# ETCD_PEER_CA_FILE=
+# ETCD_TRUSTED_CA_FILE=
+
+# [DEPRECATED] Path to the peer server TLS CA file.
+#
+# default: none
#
+# ETCD_PEER_CA_FILE=
# Path to the peer server TLS cert file.
+#
# default: none
#
# ETCD_PEER_CERT_FILE=
-#
# Path to the peer server TLS key file.
+#
# default: none
#
# ETCD_PEER_KEY_FILE=
+
+# Enable peer client cert authentication.
+#
+# default: false
+#
+# ETCD_PEER_CLIENT_CERT_AUTH=false
+
+# Path to the peer server TLS trusted CA file.
#
+# default: none
+#
+# ETCD_PEER_TRUSTED_CA_FILE=
+
+# Drop the default log level to DEBUG for all subpackages.
+#
+# default: false (INFO for all packages)
+#
+# ETCD_DEBUG=false
+
+# Set individual etcd subpackages to specific log levels.
+# An example being etcdserver=WARNING,security=DEBUG
+#
+# default: none (INFO for all packages)
+#
+# ETCD_LOG_PACKAGE_LEVELS=
# Force to create a new one_member cluster.
# It commits configuration changes in force to remove all existing members in the cluster and add itself.
# It needs to be set to restore a backup.
-# default: false
#
-# ETCD_FORCE_NEW_CLUSTER="false"
+# default: false
#
+# ETCD_FORCE_NEW_CLUSTER=false
# vim:ft=sh:
diff --git a/etcd.install b/etcd.install
index 1e3696cc88b6..da8cd7b58c7e 100644
--- a/etcd.install
+++ b/etcd.install
@@ -1,4 +1,15 @@
-ETCD_DATA_DIR="/var/lib/etcd/"
+ETCD_DATA_DIR="/var/lib/etcd"
+
+pre_upgrade() {
+cat << EOF
+ To upgrade an existing etcd deployment to 2.2, you must be running 2.1.
+ If you’re running a version of etcd before 2.1, you must upgrade to 2.1 before upgrading to 2.2.
+ And you should, probably, read the following:
+ /usr/share/doc/etcd/04_to_2_snapshot_migration.md
+ /usr/share/doc/etcd/upgrade_2_1.md
+ /usr/share/doc/etcd/upgrade_2_2.md
+EOF
+}
post_install() {
mkdir -p "${ETCD_DATA_DIR}"