summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandrewSC2020-05-31 20:50:14 -0400
committerandrewSC2020-05-31 20:50:14 -0400
commitbcf67723d99eda4d5da842aa0c1d8d21efd19c1d (patch)
tree364a92faa850798ce495b1a77e8c7858ece14153
parent8095a528d8f10ac854e7d5662c7b743e56ec5fb3 (diff)
downloadaur-bcf67723d99eda4d5da842aa0c1d8d21efd19c1d.tar.gz
Realigning pkgbuild to latest Go packaging guidelines, version bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67ccf463fd8a..bb87ce60e860 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = etcd
pkgdesc = A highly-available key value store for shared configuration and service discovery.
- pkgver = 3.4.7
+ pkgver = 3.4.9
pkgrel = 1
url = https://github.com/etcd-io/etcd
install = etcd.install
@@ -10,10 +10,10 @@ pkgbase = etcd
license = Apache
makedepends = go
backup = etc/conf.d/etcd
- source = etcd-3.4.7.tar.gz::https://github.com/etcd-io/etcd/archive/v3.4.7.tar.gz
+ source = etcd-3.4.9.tar.gz::https://github.com/etcd-io/etcd/archive/v3.4.9.tar.gz
source = 10-EnvironmentFile.conf
source = etcd.env
- sha512sums = 18851be0cbe8dabc6be8ba0c61d783f21b1fb9403256166016767926c731f1d95a1adebad9f36d43c57a424a7ac88c49b1d1ce01c2aa065e5bbbff847eb9234a
+ sha512sums = c9195cd82c82e80d852b9d3c62f424caee426e41035bce2f0c07878162fe1b90da9f3be0a0fd3966954aadfa474b213ab9654adb7da275cb16b304c4e4ba8e13
sha512sums = fa85d772929ea7e0a18bddd4b9c41d043a7f75e560eacfab67b979985e510dea694c332b5130570e47101c1ec5c25925872c6a581568390e7b141d9c6c26aae2
sha512sums = 040cee3c04dd5bb253415169d1f6f50bbccac10b687706c1b168184985c0c6c6cc67858f0c71d2ebb475891e54b370fa39b20ead5155658d01fac31d7d388324
diff --git a/PKGBUILD b/PKGBUILD
index f337921efee2..070878e79391 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: codekoala <codekoala at gmail dot com>
pkgname=etcd
-pkgver=3.4.7
+pkgver=3.4.9
pkgrel=1
pkgdesc='A highly-available key value store for shared configuration and service discovery.'
arch=('x86_64' 'armv6h' 'armv7h')
@@ -17,13 +17,16 @@ install="${pkgname}".install
source=("${pkgname}"-"${pkgver}".tar.gz::https://github.com/etcd-io/"${pkgname}"/archive/v"${pkgver}".tar.gz
10-EnvironmentFile.conf
etcd.env)
-sha512sums=('18851be0cbe8dabc6be8ba0c61d783f21b1fb9403256166016767926c731f1d95a1adebad9f36d43c57a424a7ac88c49b1d1ce01c2aa065e5bbbff847eb9234a'
+sha512sums=('c9195cd82c82e80d852b9d3c62f424caee426e41035bce2f0c07878162fe1b90da9f3be0a0fd3966954aadfa474b213ab9654adb7da275cb16b304c4e4ba8e13'
'fa85d772929ea7e0a18bddd4b9c41d043a7f75e560eacfab67b979985e510dea694c332b5130570e47101c1ec5c25925872c6a581568390e7b141d9c6c26aae2'
'040cee3c04dd5bb253415169d1f6f50bbccac10b687706c1b168184985c0c6c6cc67858f0c71d2ebb475891e54b370fa39b20ead5155658d01fac31d7d388324')
build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-trimpath -mod=vendor"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
cd "${srcdir}"/"${pkgname}"-"${pkgver}"
./build