summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2017-05-13 16:11:41 -0700
committerMike Swanson2017-05-13 16:11:41 -0700
commit9b053891a2eb2812e68797b378a91feaf9b22d46 (patch)
tree3f2bc04c44823044eccd8f1cbe0c293ae5d44ea9
parenteefa1bf8492461a9838a0c81113f89f034c21d1b (diff)
downloadaur-9b053891a2eb2812e68797b378a91feaf9b22d46.tar.gz
Update to 3.42.02
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Fix-wrong-Freedoom-IWAD-detection-fixes-7.patch73
-rw-r--r--PKGBUILD10
3 files changed, 9 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6ab6f847f26..7493283011a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Sep 28 19:30:02 UTC 2016
+# Sat May 13 23:11:07 UTC 2017
pkgbase = eternity-engine
pkgdesc = An advanced Doom port with vanilla compatibility
- pkgver = 3.40.46
- pkgrel = 5
+ pkgver = 3.42.02
+ pkgrel = 1
url = http://eternity.youfailit.net/
arch = i686
arch = x86_64
@@ -13,10 +13,8 @@ pkgbase = eternity-engine
depends = sdl_mixer
depends = sdl_net
depends = zlib
- source = https://github.com/team-eternity/eternity/archive/3.40.46.tar.gz
- source = 0001-Fix-wrong-Freedoom-IWAD-detection-fixes-7.patch
- sha256sums = 6479c127bdc1986421d0daa821131d21bd3d95621c4181d3528f1efe14c0084b
- sha256sums = f708c5838e7415e21e0ba4e7c1c01305dca5854f65159989e1fdb06c6f5d9658
+ source = https://github.com/team-eternity/eternity/archive/3.42.02.tar.gz
+ sha512sums = 12396353a8a2d9f7220251589ff6171b3146bfa41515ed89850ac6ebdf1a97c71f53fac3fa19cb8e6828c2d191eba51d238970d75fdcdaf48c4e719c2d80dc31
pkgname = eternity-engine
diff --git a/0001-Fix-wrong-Freedoom-IWAD-detection-fixes-7.patch b/0001-Fix-wrong-Freedoom-IWAD-detection-fixes-7.patch
deleted file mode 100644
index 6ff00dfdaafc..000000000000
--- a/0001-Fix-wrong-Freedoom-IWAD-detection-fixes-7.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 2dabf254717a54dea6db4dbdbac3f5ea7b6aa171 Mon Sep 17 00:00:00 2001
-From: Max Waine <bobishmax@hotmail.com>
-Date: Wed, 28 Sep 2016 16:14:22 +0100
-Subject: [PATCH] Fix wrong Freedoom IWAD detection (fixes #7)
-
----
- source/d_findiwads.cpp | 8 +++++++-
- source/d_iwad.cpp | 3 +++
- source/d_iwad.h | 1 +
- 3 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/source/d_findiwads.cpp b/source/d_findiwads.cpp
-index 765e5fb..bb9ec64 100644
---- a/source/d_findiwads.cpp
-+++ b/source/d_findiwads.cpp
-@@ -491,6 +491,7 @@ static void D_determineIWADVersion(const qstring &fullpath)
- version.gamemission = none;
- version.hassecrets = false;
- version.freedoom = false;
-+ version.freedm = false;
- version.bfgedition = false;
- version.error = false;
- version.flags = IWADF_NOERRORS;
-@@ -524,7 +525,12 @@ static void D_determineIWADVersion(const qstring &fullpath)
- case commercial: // DOOM II
- if(version.freedoom)
- {
-- if(PATHEMPTY(gi_path_fdoom)) // FreeDoom
-+ if(version.freedm)
-+ {
-+ if(PATHEMPTY(gi_path_freedm)) // FreeDM
-+ var = &gi_path_freedm;
-+ }
-+ else if(PATHEMPTY(gi_path_fdoom)) // FreeDoom
- var = &gi_path_fdoom;
- }
- else
-diff --git a/source/d_iwad.cpp b/source/d_iwad.cpp
-index ef20c30..85ca49a 100644
---- a/source/d_iwad.cpp
-+++ b/source/d_iwad.cpp
-@@ -860,6 +860,8 @@ void D_CheckIWAD(const char *iwadname, iwadcheck_t &version)
- ++sosr;
- else if(!lumpnamecmp(n, "FREEDOOM"))
- version.freedoom = true;
-+ else if(!lumpnamecmp(n, "FREEDM")) // Needed to discern freedm from freedoom2
-+ version.freedm = true;
- else if(!lumpnamecmp(n, "HACX-R"))
- ++hacx;
- else if(!lumpnamecmp(n, "M_ACPT" ) || // haleyjd 11/03/12: BFG Edition
-@@ -1369,6 +1371,7 @@ static void D_identifyIWAD()
- version.gamemission = none;
- version.hassecrets = false;
- version.freedoom = false;
-+ version.freedm = false;
- version.bfgedition = false;
- version.error = false;
- version.flags = IWADF_FATALNOTOPEN | IWADF_FATALNOTWAD;
-diff --git a/source/d_iwad.h b/source/d_iwad.h
-index f50ca5c..38e8538 100644
---- a/source/d_iwad.h
-+++ b/source/d_iwad.h
-@@ -55,6 +55,7 @@ struct iwadcheck_t
- GameMission_t gamemission;
- bool hassecrets;
- bool freedoom;
-+ bool freedm;
- bool bfgedition;
- };
-
---
-2.10.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 2614d382b473..4f91b9d3bd22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,16 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=eternity-engine
-pkgver=3.40.46
-pkgrel=5
+pkgver=3.42.02
+pkgrel=1
pkgdesc="An advanced Doom port with vanilla compatibility"
url="http://eternity.youfailit.net/"
arch=('i686' 'x86_64')
license=('GPL3')
depends=('sdl' 'sdl_mixer' 'sdl_net' 'zlib')
makedepends=('cmake')
-source=(https://github.com/team-eternity/eternity/archive/$pkgver.tar.gz
- 0001-Fix-wrong-Freedoom-IWAD-detection-fixes-7.patch)
-sha256sums=('6479c127bdc1986421d0daa821131d21bd3d95621c4181d3528f1efe14c0084b'
- 'f708c5838e7415e21e0ba4e7c1c01305dca5854f65159989e1fdb06c6f5d9658')
+source=(https://github.com/team-eternity/eternity/archive/$pkgver.tar.gz)
+sha512sums=('12396353a8a2d9f7220251589ff6171b3146bfa41515ed89850ac6ebdf1a97c71f53fac3fa19cb8e6828c2d191eba51d238970d75fdcdaf48c4e719c2d80dc31')
prepare() {
cd "eternity-$pkgver"