summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2020-11-10 20:33:08 -0800
committerMike Swanson2020-11-10 20:33:08 -0800
commitdc10b0825e25a8e63d721573a08fdf4aead44190 (patch)
tree423dc551cad30d42ffc1a9bc0159db438910f26f
parent02fc8fdc7c722f108516f47dc9c03aac4a2f1758 (diff)
downloadaur-dc10b0825e25a8e63d721573a08fdf4aead44190.tar.gz
Update to 4.01.00
Brings the package closer to the -git one, fetching from git instead of a release tarball. Eternity Engine can no longer reliabily build from a release tarball, depending on many inlined libraries instead of working with system ones.
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--0001-Fix-crashes-under-SDL-2.0.9-for-Linux.patch81
-rw-r--r--PKGBUILD27
4 files changed, 24 insertions, 100 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d674307107f..506aefd58d2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = eternity-engine
pkgdesc = An advanced Doom port with vanilla compatibility
- pkgver = 4.00.00
- pkgrel = 2
+ pkgver = 4.01.00
+ pkgrel = 1
url = http://eternity.youfailit.net/
arch = i686
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = cmake
depends = sdl2
depends = sdl2_mixer
depends = sdl2_net
depends = zlib
- source = https://github.com/team-eternity/eternity/archive/4.00.00.tar.gz
- source = 0001-Fix-crashes-under-SDL-2.0.9-for-Linux.patch
- sha512sums = 1d78e8db65d8d2da4bea00944304ec4d6bbfab90d6ef913c1e1d64f7cbf6162284f5861e3356c501731ab3b8708e8310286f16e8430aeb50d79cfc2bd8ff7a9f
- sha512sums = 1eeeefe1dd2fba0a1cb8799dc6eaaaa8989b84d0c79107ba792387fbba14a5453eb23aa83b3635f86e137dd305abf5c7f21fe1a761daaca955fc07bedcf87228
+ source = eternity::git+https://github.com/team-eternity/eternity.git#tag=4.01.00
+ source = git+https://github.com/Wohlstand/libADLMIDI.git
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = eternity-engine
diff --git a/.gitignore b/.gitignore
index 665307854be8..b7df9db5b988 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*.pkg.tar*
*.src.tar*
-*.gz
+/eternity/
+/libADLMIDI/
src
pkg
diff --git a/0001-Fix-crashes-under-SDL-2.0.9-for-Linux.patch b/0001-Fix-crashes-under-SDL-2.0.9-for-Linux.patch
deleted file mode 100644
index 7099bd776f7f..000000000000
--- a/0001-Fix-crashes-under-SDL-2.0.9-for-Linux.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 574447e0806322f8def7f82bb9110253f0e9da27 Mon Sep 17 00:00:00 2001
-From: Max Waine <bobishmax@hotmail.com>
-Date: Mon, 18 Feb 2019 13:58:07 +0000
-Subject: [PATCH] Fix crashes under SDL 2.0.9 for Linux
-
-Achieved by changing how mixbuffer_size is calculated.
----
- source/sdl/i_sdlsound.cpp | 43 ++++++---------------------------------
- 1 file changed, 6 insertions(+), 37 deletions(-)
-
-diff --git a/source/sdl/i_sdlsound.cpp b/source/sdl/i_sdlsound.cpp
-index 11b2008a..6eec181e 100644
---- a/source/sdl/i_sdlsound.cpp
-+++ b/source/sdl/i_sdlsound.cpp
-@@ -742,32 +742,6 @@ static void I_SDLCacheSound(sfxinfo_t *sound)
- S_CacheDigitalSoundLump(sound);
- }
-
--static void I_SDLDummyCallback(void *, Uint8 *, int) {}
--
--//
--// I_SDLTestSoundBufferSize
--//
--// This shouldn't be necessary except for really bad API design.
--//
--static Uint32 I_SDLTestSoundBufferSize()
--{
-- Uint32 ret = 0;
-- SDL_AudioSpec want, have;
-- want.freq = snd_samplerate;
-- want.format = MIX_DEFAULT_FORMAT;
-- want.channels = 2;
-- want.samples = audio_buffers;
-- want.callback = I_SDLDummyCallback;
--
-- if(SDL_OpenAudio(&want, &have) >= 0)
-- {
-- ret = have.size;
-- SDL_CloseAudio();
-- }
--
-- return ret;
--}
--
- //
- // I_SDLInitSound
- //
-@@ -787,16 +761,11 @@ static int I_SDLInitSound()
- if(!I_IsSoundBufferSizePowerOf2(audio_buffers))
- audio_buffers = I_MakeSoundBufferSize(audio_buffers);
-
-- // Figure out mix buffer sizes
-- mixbuffer_size = I_SDLTestSoundBufferSize() / SAMPLESIZE;
-- if(!mixbuffer_size)
-- {
-- printf("Couldn't determine sound mixing buffer size.\n");
-- nosfxparm = true;
-- nomusicparm = true;
-- return 0;
-- }
--
-+ // Figure out mix buffer sizes by dividing the results of SDL_audio.c's
-+ // SDL_CalculateAudioSpec size calculation by SAMPLESIZE. The 2 is number of channels.
-+ mixbuffer_size = ((SDL_AUDIO_BITSIZE(MIX_DEFAULT_FORMAT) / 8) * 2 * audio_buffers) /
-+ SAMPLESIZE;
-+
- if(Mix_OpenAudio(snd_samplerate, MIX_DEFAULT_FORMAT, 2, audio_buffers) < 0)
- {
- printf("Couldn't open audio with desired format.\n");
-@@ -804,7 +773,7 @@ static int I_SDLInitSound()
- nomusicparm = true;
- return 0;
- }
--
-+
- // haleyjd 10/02/08: this must be done as early as possible.
- I_SetChannels();
-
---
-2.23.0
-
diff --git a/PKGBUILD b/PKGBUILD
index aedba23b69db..43915edcccac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=eternity-engine
-pkgver=4.00.00
-pkgrel=2
+pkgver=4.01.00
+pkgrel=1
pkgdesc="An advanced Doom port with vanilla compatibility"
url="http://eternity.youfailit.net/"
arch=('i686' 'x86_64')
license=('GPL3')
depends=('sdl2' 'sdl2_mixer' 'sdl2_net' 'zlib')
-makedepends=('cmake')
-source=(https://github.com/team-eternity/eternity/archive/${pkgver}.tar.gz
- 0001-Fix-crashes-under-SDL-2.0.9-for-Linux.patch)
-sha512sums=('1d78e8db65d8d2da4bea00944304ec4d6bbfab90d6ef913c1e1d64f7cbf6162284f5861e3356c501731ab3b8708e8310286f16e8430aeb50d79cfc2bd8ff7a9f'
- '1eeeefe1dd2fba0a1cb8799dc6eaaaa8989b84d0c79107ba792387fbba14a5453eb23aa83b3635f86e137dd305abf5c7f21fe1a761daaca955fc07bedcf87228')
+makedepends=('git' 'cmake')
+source=("eternity::git+https://github.com/team-eternity/eternity.git#tag=${pkgver}"
+ 'git+https://github.com/Wohlstand/libADLMIDI.git')
+b2sums=('SKIP'
+ 'SKIP')
prepare() {
- cd "eternity-${pkgver}"
+ cd "${srcdir}/eternity"
+ git submodule init
+ git config submodule.adlmidi.url "${srcdir}/libADLMIDI"
+ git submodule update
for patch in ../*.patch; do
if [ ! -f "$patch" ]; then
@@ -28,13 +31,13 @@ prepare() {
build() {
# Cannot do in-tree build.
- mkdir "ee-build"
- cd "ee-build"
- cmake ../eternity-${pkgver} -DCMAKE_INSTALL_PREFIX=/usr
+ mkdir ee-build
+ cd ee-build
+ cmake ../eternity -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd "ee-build"
+ cd ee-build
make PREFIX=/usr DESTDIR="$pkgdir" install
}