summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Backer Dirks2021-11-09 15:35:54 +0200
committerTobias Backer Dirks2021-11-09 15:35:54 +0200
commit8ac2b4b1b7698ecdac8575946d0018afe5aefafb (patch)
tree3dacf18968746d67acef7c2c7e7435295a1a5481
downloadaur-ethlint-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cbd5bc6ad95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ethlint-git
+ pkgdesc = Ethlint (Formerly Solium) analyzes your Solidity code for style & security issues and fixes them.
+ pkgver = 1.2.5.r1.g39895c1
+ pkgrel = 1
+ url = https://github.com/duaraghav8/Ethlint
+ arch = any
+ license = MIT
+ makedepends = npm
+ makedepends = git
+ depends = nodejs
+ source = ethlint-git-1.2.5.r1.g39895c1::git+https://github.com/duaraghav8/Ethlint
+ sha512sums = SKIP
+
+pkgname = ethlint-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..551a8f8989bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Tobias Backer Dirks <omgitsaheadcrab@gmail.com>
+
+_pkgname=ethlint
+pkgname=$_pkgname-git
+_pkgauthor=omgitsaheadcrab
+pkgver=1.2.5.r1.g39895c1
+pkgrel=1
+pkgdesc='Ethlint (Formerly Solium) analyzes your Solidity code for style & security issues and fixes them.'
+arch=('any')
+url='https://github.com/duaraghav8/Ethlint'
+license=('MIT')
+depends=(nodejs)
+makedepends=(npm git)
+source=("${pkgname}-${pkgver}::git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ npm install --production
+}
+
+package() {
+ local _npmdir="${pkgdir}/usr/lib/node_modules"
+ mkdir -p "${_npmdir}"
+ cp -R "${srcdir}/${pkgname}-${pkgver}" "${_npmdir}/${_pkgname}"
+ local _bindir="${pkgdir}/usr/bin"
+ mkdir -p "${_bindir}"
+ ln -s "/usr/lib/node_modules/${_pkgname}/bin/solium.js" "${_bindir}/solium"
+}