summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorggilestro2019-07-03 09:37:18 +0100
committerggilestro2019-07-03 09:37:18 +0100
commit3c6bc9a3f539e25080bc883302defb4c5f06401c (patch)
tree01b3f2c0b3970ef77b2028f510dafe8c15f67099
parent2151f88aa30199aae3cd803555867321e85698dc (diff)
downloadaur-3c6bc9a3f539e25080bc883302defb4c5f06401c.tar.gz
Added some important dependencies. Ready for real first test
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD4
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6afb8fd6d98..7c3f985f432f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,18 +8,18 @@ pkgbase = ethoscope-device
license = GPL3
makedepends = git
makedepends = gcc-fortran
- makedepends = rsync
- makedepends = wget
- makedepends = fping
- makedepends = ntp
- makedepends = fake-hwclock
- makedepends = openssh
- makedepends = mariadb
- makedepends = dnsmasq
- makedepends = wpa_supplicant
- makedepends = ifplugd
- makedepends = wpa_action
- makedepends = base-devel
+ depends = avahi
+ depends = rsync
+ depends = wget
+ depends = fping
+ depends = ntp
+ depends = fake-hwclock
+ depends = openssh
+ depends = mariadb
+ depends = dnsmasq
+ depends = wpa_supplicant
+ depends = ifplugd
+ depends = wpa_action
depends = opencv
depends = hdf5
depends = gtk3
@@ -37,6 +37,7 @@ pkgbase = ethoscope-device
depends = python-greenlet
depends = python-monotonic
depends = python-picamera
+ depends = python-zeroconf
provides = ethoscope-device
source = ethoscope-device::git+https://github.com/gilestrolab/ethoscope.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2a47dc8f9725..e562a25f5560 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgdesc="A platform from monitoring animal behaviour in real time from a raspber
arch=('any')
url="http://lab.gilest.ro/ethoscope"
license=('GPL3')
-makedepends=('git' 'gcc-fortran' 'rsync' 'wget' 'fping' 'ntp' 'fake-hwclock' 'openssh' 'mariadb' 'dnsmasq' 'wpa_supplicant' 'ifplugd' 'wpa_action' 'base-devel' )
-depends=('opencv' 'hdf5' 'gtk3' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera')
+makedepends=('git' 'gcc-fortran' )
+depends=('avahi' 'rsync' 'wget' 'fping' 'ntp' 'fake-hwclock' 'openssh' 'mariadb' 'dnsmasq' 'wpa_supplicant' 'ifplugd' 'wpa_action' 'opencv' 'hdf5' 'gtk3' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera' 'python-zeroconf')
provides=('ethoscope-device')
install="ethoscope-device.install"
source=("$pkgname::git+https://github.com/gilestrolab/ethoscope.git")