summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgio Gilestro2022-03-16 18:31:10 +0000
committerGiorgio Gilestro2022-03-16 18:31:10 +0000
commit457552955a7b56d8f65b9f03be4e99f35a8477ae (patch)
tree6bc842aba20b4834ac6398ed437c762469766acb
parent4ed47959a8ba1e8ab501dc952cb3fa4a7398787d (diff)
downloadaur-457552955a7b56d8f65b9f03be4e99f35a8477ae.tar.gz
Added dependency to python-opencv
enable ethoscope_listener service at installation fixes git origin after upgrade
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--ethoscope-device.install10
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01dce4ac3a7c..2d32f2ddf51b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,7 +21,7 @@ pkgbase = ethoscope-device
depends = wpa_supplicant
depends = ifplugd
depends = qt5-base
- depends = opencv
+ depends = python-opencv
depends = hdf5
depends = gtk3
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 3c047e9e6ecc..65ec78c2aa71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('any')
url="http://lab.gilest.ro/ethoscope"
license=('GPL3')
makedepends=('git' 'gcc-fortran' )
-depends=('git' 'avahi' 'rsync' 'wget' 'fping' 'ntp' 'openssh' 'mariadb' 'dnsmasq' 'f2fs-tools' 'wpa_supplicant' 'ifplugd' 'qt5-base' 'opencv' 'hdf5' 'gtk3' 'python' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera' 'python-zeroconf')
+depends=('git' 'avahi' 'rsync' 'wget' 'fping' 'ntp' 'openssh' 'mariadb' 'dnsmasq' 'f2fs-tools' 'wpa_supplicant' 'ifplugd' 'qt5-base' 'python-opencv' 'hdf5' 'gtk3' 'python' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera' 'python-zeroconf')
provides=('ethoscope-device')
install="ethoscope-device.install"
source=("$pkgname::git+https://github.com/gilestrolab/ethoscope.git")
diff --git a/ethoscope-device.install b/ethoscope-device.install
index 4ae4c540ccfe..f3a0495d7e03 100644
--- a/ethoscope-device.install
+++ b/ethoscope-device.install
@@ -63,9 +63,9 @@ post_install() {
echo 'driftfile /var/lib/ntp/ntp.drift' >> /etc/ntp.conf
echo "enabling DEVICE specific systemd service files"
- systemctl enable ethoscope_device.service ethoscope_update.service
+ systemctl enable ethoscope_device.service ethoscope_listener.service ethoscope_update.service
systemctl enable ntpd.service mysqld.service sshd.service mysqld.service avahi-daemon.service
- systemctl enable fake-hwclock fake-hwclock-save.timer
+ #systemctl enable fake-hwclock fake-hwclock-save.timer
echo "Set up mysql database"
mysql_install_db --user=mysql --basedir=/usr --datadir=/var/lib/mysql
@@ -125,16 +125,16 @@ post_install() {
post_upgrade() {
echo "changing the remote GIT source to BARE on node"
cd /opt/ethoscope-device
- git remote set-url origin git://node/srv/git/ethoscope.git
+ git remote set-url origin git://node/ethoscope.git
#setting branch
- git checkout python3.7
+ git checkout dev
}
# arg 1: the old package version
pre_remove() {
echo "disabling systemd service files"
- systemctl disable ethoscope_device.service ethoscope_update.service
+ systemctl disable ethoscope_device.service ethoscope_listener.service ethoscope_update.service
}
## arg 1: the old package version