summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorggilestro2020-05-02 10:44:15 +0100
committerggilestro2020-05-02 10:44:15 +0100
commit799d201bb08a928ee2d1ed19e1064476fa4fa902 (patch)
treeba55387e618d1fe92c3c304f656d8dbe443e0150
parent5e771908f7be1df6270ab4f71fcdaace1762c886 (diff)
downloadaur-799d201bb08a928ee2d1ed19e1064476fa4fa902.tar.gz
Removed dependency to python 3.8.0 because picamera now works with python 3.8.2
Removed dependency to wpactiond because it is no longer needed Fixed some typos in the post installation hook
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--ethoscope-device.install13
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c57ab8d784e6..0aea7c5e1f43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ethoscope-device
pkgdesc = A platform from monitoring animal behaviour in real time from a raspberry pi - Device version
pkgver = r1702.g1c43fc3
- pkgrel = 2
+ pkgrel = 1
url = http://lab.gilest.ro/ethoscope
install = ethoscope-device.install
arch = any
@@ -21,12 +21,11 @@ pkgbase = ethoscope-device
depends = f2fs-tools
depends = wpa_supplicant
depends = ifplugd
- depends = wpa_actiond
depends = qt5-base
depends = opencv
depends = hdf5
depends = gtk3
- depends = python=3.8.0
+ depends = python
depends = python-pip
depends = python-numpy
depends = python-scipy
diff --git a/PKGBUILD b/PKGBUILD
index 97a132d0f753..0e3eb97ebb22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=ethoscope-device
pkgver=r1702.g1c43fc3
-pkgrel=2
+pkgrel=1
pkgdesc="A platform from monitoring animal behaviour in real time from a raspberry pi - Device version"
arch=('any')
url="http://lab.gilest.ro/ethoscope"
license=('GPL3')
makedepends=('git' 'gcc-fortran' )
-depends=('git' 'avahi' 'rsync' 'wget' 'fping' 'ntp' 'fake-hwclock-git' 'openssh' 'mariadb' 'dnsmasq' 'f2fs-tools' 'wpa_supplicant' 'ifplugd' 'wpa_actiond' 'qt5-base' 'opencv' 'hdf5' 'gtk3' 'python=3.8.0' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera' 'python-zeroconf')
+depends=('git' 'avahi' 'rsync' 'wget' 'fping' 'ntp' 'fake-hwclock-git' 'openssh' 'mariadb' 'dnsmasq' 'f2fs-tools' 'wpa_supplicant' 'ifplugd' 'qt5-base' 'opencv' 'hdf5' 'gtk3' 'python' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera' 'python-zeroconf')
provides=('ethoscope-device')
install="ethoscope-device.install"
source=("$pkgname::git+https://github.com/gilestrolab/ethoscope.git")
diff --git a/ethoscope-device.install b/ethoscope-device.install
index ea07318f091a..949177e5a2a5 100644
--- a/ethoscope-device.install
+++ b/ethoscope-device.install
@@ -64,7 +64,8 @@ post_install() {
echo "enabling DEVICE specific systemd service files"
systemctl enable ethoscope_device.service ethoscope_update.service
- systemctl enable ntpd.service mysqld.service fake-hwclock fake-hwclock-save.timer sshd.service mysqld.service avahi-daemon.service
+ systemctl enable ntpd.service mysqld.service sshd.service mysqld.service avahi-daemon.service
+ systemctl enable fake-hwclock fake-hwclock-save.timer
echo "Set up mysql database"
mysql_install_db --user=mysql --basedir=/usr --datadir=/var/lib/mysql
@@ -83,15 +84,15 @@ post_install() {
echo 'cma_lwm=' >> /boot/config.txt
echo 'cma_hwm=' >> /boot/config.txt
echo 'cma_offline_start=' >> /boot/config.txt
- echo 'hdmi_force_hotplug=1` >> /boot/config.txt
+ echo 'hdmi_force_hotplug=1' >> /boot/config.txt
echo 'Loading bcm2835 module'
- echo "bcm2835-v4l2" > /etc/modules-load.d/picamera.conf
+ echo 'bcm2835-v4l2' > /etc/modules-load.d/picamera.conf
echo "limiting journal log space"
echo 'SystemMaxUse=250MB' >> /etc/systemd/journald.conf
echo "generating locale"
- echo "en_GB.UTF-8 UTF-8\n" >> /etc/locale.gen
+ echo "en_GB.UTF-8 UTF-8" >> /etc/locale.gen
locale-gen
@@ -102,7 +103,7 @@ post_install() {
## arg 1: the new package version
## arg 2: the old package version
#pre_upgrade() {
- # do something here
+ # do something here
#}
# arg 1: the new package version
@@ -124,5 +125,5 @@ pre_remove() {
## arg 1: the old package version
#post_remove() {
- # do something here
+ # do something here
#}