summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgio Gilestro2020-11-10 11:03:46 +0000
committerGiorgio Gilestro2020-11-10 11:03:46 +0000
commit8d7aef752a34c4a54fcb10e93ca4e35b8821c7c0 (patch)
tree1dcfc2a494d6a4d7728b174a539eccc216ccef28
parentb95407776e81da445eef08571593157a1e513090 (diff)
downloadaur-8d7aef752a34c4a54fcb10e93ca4e35b8821c7c0.tar.gz
Adding support for camera auto grey world to the boot/config.txt file to fix https://github.com/raspberrypi/firmware/issues/1167
-rw-r--r--PKGBUILD8
-rw-r--r--ethoscope-device.install4
2 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e3eb97ebb22..95a7de85177b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,12 +27,16 @@ package() {
#setting python3 branch
cd "${srcdir}/${pkgname}"
- git checkout python3.7
-
+ git checkout dev
+
#cp node server and node updater
cd "${srcdir}"
cp -R --no-dereference --preserve=mode,links -v * "${pkgdir}/opt/${pkgname}"
ln -s /opt/ethoscope-device/scripts/ethoscope_updater "${pkgdir}/opt/"
+
+ #changing the remote GIT source to local BARE created during installation
+ cd "${pkgdir}/opt/${pkgname}"
+ git remote set-url origin /srv/git/ethoscope.git
#install python package
#cd "${srcdir}/${pkgname}/src"
diff --git a/ethoscope-device.install b/ethoscope-device.install
index 8be1c2110141..84762104a111 100644
--- a/ethoscope-device.install
+++ b/ethoscope-device.install
@@ -93,6 +93,10 @@ post_install() {
echo 'cma_offline_start=' >> /boot/config.txt
echo 'hdmi_force_hotplug=1' >> /boot/config.txt
+
+ # https://github.com/raspberrypi/firmware/issues/1167
+ echo 'awb_auto_is_greyworld=1' >> /boot/config.txt
+
echo 'Loading bcm2835 module'
echo 'bcm2835-v4l2' > /etc/modules-load.d/picamera.conf