summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgio Gilestro2023-03-07 15:35:14 +0000
committerGiorgio Gilestro2023-03-07 15:35:14 +0000
commit9fa4c514a23bb7b88f3686c3744db4a2e727c6e1 (patch)
tree1bc10d5af616adafd335714ac223b43408c63698
parentea571f20384fb5dff590bd6ae99882e66209a57b (diff)
downloadaur-9fa4c514a23bb7b88f3686c3744db4a2e727c6e1.tar.gz
Install python-pyusb as dependency, add date and time to issue file
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--ethoscope-device.install15
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 390cd4c15255..1e8858d512c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ethoscope-device
pkgdesc = A platform from monitoring animal behaviour in real time from a raspberry pi - Device version
pkgver = r1702.g1c43fc3
- pkgrel = 4
+ pkgrel = 5
url = http://lab.gilest.ro/ethoscope
install = ethoscope-device.install
arch = any
@@ -42,6 +42,7 @@ pkgbase = ethoscope-device
depends = python-monotonic
depends = python-picamera
depends = python-zeroconf
+ depends = python-pyusb
provides = ethoscope-device
source = ethoscope-device::git+https://github.com/gilestrolab/ethoscope.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ab991469d12f..9d7ffc55eb82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=ethoscope-device
pkgver=r1702.g1c43fc3
-pkgrel=4
+pkgrel=5
pkgdesc="A platform from monitoring animal behaviour in real time from a raspberry pi - Device version"
arch=('any')
url="http://lab.gilest.ro/ethoscope"
license=('GPL3')
makedepends=('git' 'gcc-fortran' )
-depends=('git' 'avahi' 'rsync' 'wget' 'fping' 'ntp' 'nss-mdns' 'openssh' 'mariadb' 'dnsmasq' 'f2fs-tools' 'i2c-tools' 'wpa_supplicant' 'ifplugd' 'qt5-base' 'python-opencv' 'hdf5' 'gtk3' 'python' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera' 'python-zeroconf')
+depends=('git' 'avahi' 'rsync' 'wget' 'fping' 'ntp' 'nss-mdns' 'openssh' 'mariadb' 'dnsmasq' 'f2fs-tools' 'i2c-tools' 'wpa_supplicant' 'ifplugd' 'qt5-base' 'python-opencv' 'hdf5' 'gtk3' 'python' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera' 'python-zeroconf' 'python-pyusb')
provides=('ethoscope-device')
install="ethoscope-device.install"
source=("$pkgname::git+https://github.com/gilestrolab/ethoscope.git")
diff --git a/ethoscope-device.install b/ethoscope-device.install
index e0ba45ff17b5..31d27a694bcc 100644
--- a/ethoscope-device.install
+++ b/ethoscope-device.install
@@ -26,19 +26,20 @@ post_install() {
echo "create the default network configuration files"
echo $'[Match]\nName=eth0\n\n[Network]\nDHCP=yes\n\n[DHCPv4]\nRouteMetric=10\n' > /etc/systemd/network/20-wired.network
- echo $'[Match]\nName=wlan0\n\n\n[Network]\nDHCP=yes\n\n[DHCPv4]\nRouteMetric=20\n' > /etc/systemd/network/25-wireless.network
+ echo $'[Match]\nName=wlan0\n\n\n[Network]\nDHCP=yes\n\n[DHCPv4]\nRouteMetric=20\n' > /etc/systemd/network/25-wireless.network
systemctl enable systemd-networkd --now
- wpa_passphrase ETHOSCOPE_WIFI ETHOSCOPE_1234 > /etc/wpa_supplicant/wpa_supplicant-wlan0.conf
+ wpa_passphrase ETHOSCOPE_WIFI ETHOSCOPE_1234 > /etc/wpa_supplicant/wpa_supplicant-wlan0.conf
systemctl enable wpa_supplicant --now
systemctl enable wpa_supplicant@wlan0.service
- #create a verbose login prompt
- echo 'Ethoscope Linux \r (\n) (\l)' > /etc/issue
- echo 'Ethernet IP: \4{eth0}' >> /etc/issue
- echo 'WIFI IP: \4{wlan0}' >> /etc/issue
+ #create a verbose login prompt
+ echo 'Ethoscope Linux \r (\n) (\l)' > /etc/issue
+ echo 'Ethernet IP: \4{eth0}' >> /etc/issue
+ echo 'WIFI IP: \4{wlan0}' >> /etc/issue
+ echo 'Time on Device: \d \t' >> /etc/issue
- echo "activates remote journal upload"
+ echo "activates remote journal upload"
echo $'[Upload]\nURL=http://node:19532\n' > /etc/systemd/journal-upload.conf
echo "configure the NTP file"