summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgio Gilestro2023-02-03 17:20:22 +0000
committerGiorgio Gilestro2023-02-03 17:20:22 +0000
commitb479c1e8d6fc59c6f128f028f8644a6c77718791 (patch)
treea5d85fe16d05d05a94dcd60432096066efc18b37
parent2b1b26c5d1bb48ebe5d90c1bb3e450305de376ad (diff)
downloadaur-b479c1e8d6fc59c6f128f028f8644a6c77718791.tar.gz
Adding the nss-mdns package
Customising the /etc/issue welcome to add IP addresses
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16e9f43dd25a..853d337aed48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,6 +14,7 @@ pkgbase = ethoscope-device
depends = wget
depends = fping
depends = ntp
+ depends = nss-mdns
depends = openssh
depends = mariadb
depends = dnsmasq
diff --git a/PKGBUILD b/PKGBUILD
index 8d26c89ecf34..59d03b687c5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('any')
url="http://lab.gilest.ro/ethoscope"
license=('GPL3')
makedepends=('git' 'gcc-fortran' )
-depends=('git' 'avahi' 'rsync' 'wget' 'fping' 'ntp' 'openssh' 'mariadb' 'dnsmasq' 'f2fs-tools' 'i2c-tools' 'wpa_supplicant' 'ifplugd' 'qt5-base' 'python-opencv' 'hdf5' 'gtk3' 'python' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera' 'python-zeroconf')
+depends=('git' 'avahi' 'rsync' 'wget' 'fping' 'ntp' 'nss-mdns' 'openssh' 'mariadb' 'dnsmasq' 'f2fs-tools' 'i2c-tools' 'wpa_supplicant' 'ifplugd' 'qt5-base' 'python-opencv' 'hdf5' 'gtk3' 'python' 'python-pip' 'python-numpy' 'python-scipy' 'python-bottle' 'python-pyserial' 'python-mysql-connector' 'python-netifaces' 'python-cherrypy' 'python-eventlet' 'python-gitpython' 'python-dnspython' 'python-greenlet' 'python-monotonic' 'python-picamera' 'python-zeroconf')
provides=('ethoscope-device')
install="ethoscope-device.install"
source=("$pkgname::git+https://github.com/gilestrolab/ethoscope.git")
@@ -24,7 +24,7 @@ package() {
install -dm0755 $pkgdir/opt
install -dm0755 $pkgdir/ethoscope_data
install -dm0755 $pkgdir/usr/lib/systemd/system/
-
+
#setting python3 branch
cd "${srcdir}/${pkgname}"
git checkout dev
@@ -37,7 +37,7 @@ package() {
#changing the remote GIT source to local BARE created during installation
cd "${pkgdir}/opt/${pkgname}"
git remote set-url origin git://node/ethoscope.git
-
+
#install service files
cd "${srcdir}"/"${pkgname}"/scripts/
install -D --mode=0755 ethoscope_device.service ethoscope_listener.service ethoscope_GPIO_listener.service "${pkgdir}/usr/lib/systemd/system/"
@@ -48,7 +48,12 @@ python /opt/ethoscope-device/src/scripts/ethoclient.py $@
EOF
chmod +x /usr/bin/ethoclient
-
+ tee -a /etc/issue <<EOF
+Ethoscope Linux \r (\n) (\l)
+Ethernet IP: \4{eth0}
+WIFI IP: \4{wlan0}
+EOF
+
cd "${srcdir}"/"${pkgname}"/scripts/ethoscope_updater/
install -D --mode=0755 ethoscope_update.service "${pkgdir}/usr/lib/systemd/system/"