summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2015-06-08 18:50:35 -0400
commit52596d409690fcb6b00101c534497132d38c1ac5 (patch)
tree1d6bd0392921eaa829016066f6b79923cb081308
downloadaur-52596d409690fcb6b00101c534497132d38c1ac5.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD68
-rw-r--r--etqw.desktop12
-rw-r--r--etqw.install30
-rw-r--r--etqw.launcher6
-rw-r--r--etqwded.launcher6
7 files changed, 154 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5a092b241db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = etqw
+ pkgdesc = Enemy Territory: Quake Wars is a commercial team and class-based multiplayer game. You need the retail DVD to play.
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://zerowing.idsoftware.com/linux/etqw/
+ install = etqw.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = unzip
+ depends = libgl
+ depends = sdl
+ depends = gcc-libs
+ depends = zlib
+ depends = libjpeg
+ conflicts = bin32-etqw
+ source = etqw.launcher
+ source = etqwded.launcher
+ source = etqw.desktop
+ source = ftp://ftp.i3d.net/Games/Enemy%20Territory%20Quake%20Wars/Patches/ETQW-client-1.5-full.x86.run
+ md5sums = 3cbe2e753a7ab8406180ae2a8b7a1aa8
+ md5sums = a3769be79f6ff5071d89f908078397dd
+ md5sums = 1ccd43afd8b418333b49495648dc7f2a
+ md5sums = 28fd825fcd9f6227827230b319e481cf
+
+pkgname = etqw
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..233b30f88452
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
+
+pkgname=etqw
+pkgver=1.5
+pkgrel=1
+pkgdesc="Enemy Territory: Quake Wars is a commercial team and class-based multiplayer game. You need the retail DVD to play."
+arch=('i686' 'x86_64')
+url="http://zerowing.idsoftware.com/linux/etqw/"
+license=('custom')
+if [ "$CARCH" = "x86_64" ]; then
+ depends=('lib32-alsa-lib' 'lib32-libgl' 'lib32-sdl' 'lib32-gcc-libs' 'lib32-zlib' 'lib32-libjpeg')
+else
+ depends=('libgl' 'sdl' 'gcc-libs' 'zlib' 'libjpeg')
+fi
+makedepends=('unzip')
+conflicts=('bin32-etqw')
+install='etqw.install'
+source=('etqw.launcher' 'etqwded.launcher' 'etqw.desktop' \
+"ftp://ftp.i3d.net/Games/Enemy%20Territory%20Quake%20Wars/Patches/ETQW-client-1.5-full.x86.run")
+md5sums=('3cbe2e753a7ab8406180ae2a8b7a1aa8'
+ 'a3769be79f6ff5071d89f908078397dd'
+ '1ccd43afd8b418333b49495648dc7f2a'
+ '28fd825fcd9f6227827230b319e481cf')
+
+build() {
+ # Create Destination Directories
+ install -d $startdir/pkg/opt/
+
+ # Unzip Linux Client Data
+ unzip -qqo $startdir/src/ETQW-client-${pkgver}-full.x86.run -d $startdir/src/ data/*
+
+ # Move Linux Client Data to Destination Directory
+ mv $startdir/src/data $startdir/pkg/opt/etqw
+
+ # Make Binaries/Scripts Executable
+ chmod +x $startdir/pkg/opt/etqw/{etqw,etqw-dedicated,etqw.x86,*.so,*.so.*,pb/*.so}
+
+ # Fix Bots Directory Permissions
+ chmod 755 $startdir/pkg/opt/etqw/base/bots
+
+ # Install License (ETQW)
+ install -D -m 644 $startdir/pkg/opt/etqw/EULA.txt \
+ $startdir/pkg/usr/share/licenses/$pkgname/EULA.txt
+
+ # Install License (PunkBuster)
+ install -D -m 644 $startdir/pkg/opt/etqw/pb/PBEULA.txt \
+ $startdir/pkg/usr/share/licenses/$pkgname/PBEULA.txt
+
+ # Install Launcher (Client)
+ install -D -m 755 $startdir/src/etqw.launcher \
+ $startdir/pkg/usr/bin/etqw
+
+ # Install Launcher (Server)
+ install -D -m 755 $startdir/src/etqwded.launcher \
+ $startdir/pkg/usr/bin/etqw-dedicated
+
+ # Install Desktop File
+ install -D -m 644 $startdir/src/etqw.desktop \
+ $startdir/pkg/usr/share/applications/etqw.desktop
+
+ # Install Icon File
+ install -D -m 644 $startdir/pkg/opt/etqw/etqw_icon.png \
+ $startdir/pkg/usr/share/pixmaps/etqw.png
+
+ # Create Directories for Retail Files
+ install -d $startdir/pkg/opt/etqw/base/{megatextures,video}
+}
+
diff --git a/etqw.desktop b/etqw.desktop
new file mode 100644
index 000000000000..69c172a57b33
--- /dev/null
+++ b/etqw.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Enemy Territory: Quake Wars
+GenericName=ET: Quake Wars
+Comment=Enemy Territory: Quake Wars
+Exec=/usr/bin/etqw
+Icon=/usr/share/pixmaps/etqw.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Qt;KDE;GNOME;Application;Game;
+
diff --git a/etqw.install b/etqw.install
new file mode 100644
index 000000000000..2a44d91ba562
--- /dev/null
+++ b/etqw.install
@@ -0,0 +1,30 @@
+
+post_install() {
+ echo ">>> You must read and agree to the terms in the EULAs found"
+ echo ">>> in /usr/share/licenses/etqw/ before using this software!"
+ echo ">>>"
+ echo ">>> Copy the following files off your retail DVD:"
+ echo ">>>"
+ echo ">>> Setup/Data/base/pak*.pk4 to /opt/etqw/base/"
+ echo ">>> Setup/Data/base/zpak*.pk4 to /opt/etqw/base/"
+ echo ">>> Setup/Data/base/megatextures/* to /opt/etqw/base/megatextures"
+ echo ">>> Setup/Data/base/video/* to /opt/etqw/base/video"
+ echo ">>>"
+ echo ">>> When you have the data files installed, start the game:"
+ echo ">>> Client: etqw"
+ echo ">>> Server: etqw-dedicated"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*
+
diff --git a/etqw.launcher b/etqw.launcher
new file mode 100644
index 000000000000..1468587a9162
--- /dev/null
+++ b/etqw.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/etqw"
+./etqw $*
+exit $?
+
diff --git a/etqwded.launcher b/etqwded.launcher
new file mode 100644
index 000000000000..d9e6180ca6b0
--- /dev/null
+++ b/etqwded.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/etqw"
+./etqw-dedicated $*
+exit $?
+