summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Whetter2015-06-08 11:55:39 +0100
committerAshley Whetter2015-06-08 11:55:39 +0100
commitb992aae23470499fce63f94e726a0587ca040425 (patch)
treebe5b2814b18f31c02d5b743576c39c84a0be6fec
downloadaur-etqw-demo.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD68
-rw-r--r--etqw-demo-ded.launcher6
-rw-r--r--etqw-demo.desktop12
-rw-r--r--etqw-demo.launcher6
5 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..634211ad887b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = etqw-demo
+ pkgdesc = Enemy Territory: Quake Wars demo
+ pkgver = 2
+ pkgrel = 3
+ url = http://zerowing.idsoftware.com/linux/etqw/ETQWFrontPage/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = unzip
+ source = etqw-demo.launcher
+ source = etqw-demo-ded.launcher
+ source = etqw-demo.desktop
+ source = ftp://ftp.idsoftware.com/idstuff/etqw/ETQW-demo2-client-full.r1.x86.run
+ md5sums = 1b1826f6a4ee23228fec629412c29367
+ md5sums = 849d3ac67cdcdf8ee7caca721736fb41
+ md5sums = 477b276b244215451886d2864bbe6406
+ md5sums = 11f5a882127a917b6c8b648ffa22da74
+ depends_i686 = libgl
+ depends_i686 = sdl
+ depends_i686 = gcc-libs
+ depends_i686 = zlib
+ depends_i686 = libjpeg
+ depends_x86_64 = lib32-alsa-lib
+ depends_x86_64 = lib32-libgl
+ depends_x86_64 = lib32-sdl
+ depends_x86_64 = lib32-gcc-libs
+ depends_x86_64 = lib32-zlib
+ depends_x86_64 = lib32-libjpeg
+ optdepends_x86_64 = lib32-nvidia-utils: Accelerated 3D with the NVIDIA binary blob video driver
+ optdepends_x86_64 = lib32-catalyst-utils: Accelerated 3D with the AMD/ATI binary blob video driver
+
+pkgname = etqw-demo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20dc8888cd1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Ashley Whetter <(firstname) @ awhetter.co.uk>
+
+pkgname=etqw-demo
+pkgver=2
+pkgrel=3
+pkgdesc="Enemy Territory: Quake Wars demo"
+arch=('i686' 'x86_64')
+url="http://zerowing.idsoftware.com/linux/etqw/ETQWFrontPage/"
+license=('custom')
+
+depends_x86_64=('lib32-alsa-lib' 'lib32-libgl' 'lib32-sdl' 'lib32-gcc-libs' 'lib32-zlib' 'lib32-libjpeg')
+optdepends_x86_64=('lib32-nvidia-utils: Accelerated 3D with the NVIDIA binary blob video driver'
+'lib32-catalyst-utils: Accelerated 3D with the AMD/ATI binary blob video driver')
+
+depends_i686=('libgl' 'sdl' 'gcc-libs' 'zlib' 'libjpeg')
+
+makedepends=('unzip')
+source=('etqw-demo.launcher' 'etqw-demo-ded.launcher' 'etqw-demo.desktop' \
+'ftp://ftp.idsoftware.com/idstuff/etqw/ETQW-demo2-client-full.r1.x86.run')
+#Mirrors: http://www.filewatcher.com/m/ETQW-demo2-client-full.r1.x86.run.691248874.0.0.html
+md5sums=('1b1826f6a4ee23228fec629412c29367'
+ '849d3ac67cdcdf8ee7caca721736fb41'
+ '477b276b244215451886d2864bbe6406'
+ '11f5a882127a917b6c8b648ffa22da74')
+
+build() {
+ # Create Destination Directories
+ install -d $pkgdir/opt/etqw-demo
+ install -d $pkgdir/usr/bin
+
+ # Unzip Linux Client Data
+ unzip -qqo $srcdir/ETQW-demo${pkgver}-client-full.r1.x86.run -x scripts/* guis/* -d $pkgdir/opt/ && msg Finished Extracting
+}
+
+package() {
+ # Move Linux Client Data to Destination Directory
+ mv $pkgdir/opt/data/* $pkgdir/opt/etqw-demo/
+
+ # Make Binaries/Scripts Executable
+ chmod +x $pkgdir/opt/etqw-demo/{etqw,etqw-dedicated,etqw.x86,*.so,*.so.*,pb/*.so}
+
+ # Fix Bots Directory Permissions
+ chmod 755 $pkgdir/opt/etqw-demo/base/bots
+
+ # Install License (ETQW)
+ install -D -m 644 $pkgdir/opt/etqw-demo/EULA.txt \
+ $pkgdir/usr/share/licenses/$pkgname/EULA.txt
+
+ # Install License (PunkBuster)
+ install -D -m 644 $pkgdir/opt/etqw-demo/pb/PBEULA.txt \
+ $pkgdir/usr/share/licenses/$pkgname/PBEULA.txt
+
+ # Install Launcher (Client)
+ install -D -m 755 $srcdir/etqw-demo.launcher \
+ $pkgdir/usr/bin/etqw-demo
+
+ # Install Launcher (Server)
+ install -D -m 755 $srcdir/etqw-demo-ded.launcher \
+ $pkgdir/usr/bin/etqw-demo-dedicated
+
+ # Install Desktop File
+ install -D -m 644 $srcdir/etqw-demo.desktop \
+ $pkgdir/usr/share/applications/etqw-demo.desktop
+
+ # Install Icon File
+ install -D -m 644 $pkgdir/opt/etqw-demo/etqw_icon.png \
+ $pkgdir/usr/share/pixmaps/etqw-demo.png
+}
diff --git a/etqw-demo-ded.launcher b/etqw-demo-ded.launcher
new file mode 100644
index 000000000000..480febe8c095
--- /dev/null
+++ b/etqw-demo-ded.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/etqw-demo"
+./etqw-dedicated $*
+exit $?
+
diff --git a/etqw-demo.desktop b/etqw-demo.desktop
new file mode 100644
index 000000000000..294d398326f0
--- /dev/null
+++ b/etqw-demo.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Enemy Territory: Quake Wars Demo
+GenericName=ET: Quake Wars Demo
+Comment=Enemy Territory: Quake Wars Demo
+Exec=/usr/bin/etqw-demo
+Icon=/usr/share/pixmaps/etqw-demo.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Qt;KDE;GNOME;Application;Game;
+
diff --git a/etqw-demo.launcher b/etqw-demo.launcher
new file mode 100644
index 000000000000..a1e40ea64b09
--- /dev/null
+++ b/etqw-demo.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/etqw-demo"
+./etqw $*
+exit $?
+