summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2022-04-04 12:50:58 +0200
committerMassimiliano Torromeo2022-04-04 12:50:58 +0200
commit112e639a5d7fd344b4daf585f65f2b0c02c64e9a (patch)
tree1f5398cc5d5b497136f5dc1d2e002322ff77cb97
parentab96f1e068e4224ae288107e598ff68d0201a228 (diff)
downloadaur-112e639a5d7fd344b4daf585f65f2b0c02c64e9a.tar.gz
removed unnecessary install file that causes double compilation of dkms modules
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD38
-rw-r--r--evdi.install20
3 files changed, 15 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b9a3b8eea38..e5ccf0406a2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = evdi
pkgdesc = A Linux® kernel module that enables management of multiple screens.
pkgver = 1.10.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/DisplayLink/evdi
- install = evdi.install
changelog = evdi.Changelog
arch = i686
arch = x86_64
@@ -11,7 +10,7 @@ pkgbase = evdi
depends = glibc
depends = dkms
depends = libdrm
- source = evdi-1.10.1-1.tar.gz::https://github.com/DisplayLink/evdi/archive/v1.10.1.tar.gz
- md5sums = 4f2f91ade5e648e3526be3e6bcc72f61
+ source = https://github.com/DisplayLink/evdi/archive/v1.10.1/evdi-1.10.1.tar.gz
+ sha256sums = 4c6fe26b91b5e6490b80e4c30de110d72daf19e1d162e14a2654eee3fec19087
pkgname = evdi
diff --git a/PKGBUILD b/PKGBUILD
index 3ba86b474eef..2c5b6593badb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,15 @@
pkgname=evdi
pkgver=1.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Linux® kernel module that enables management of multiple screens."
arch=('i686' 'x86_64')
url="https://github.com/DisplayLink/evdi"
license=('GPL')
-groups=()
depends=(glibc dkms libdrm)
-makedepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=$pkgname.install
changelog=$pkgname.Changelog
-source=($pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/DisplayLink/evdi/archive/v$pkgver.tar.gz)
-noextract=()
-md5sums=('4f2f91ade5e648e3526be3e6bcc72f61')
+source=(https://github.com/DisplayLink/evdi/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('4c6fe26b91b5e6490b80e4c30de110d72daf19e1d162e14a2654eee3fec19087')
prepare() {
cd "$pkgname-$pkgver"
@@ -30,26 +20,22 @@ prepare() {
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
- patch -Np1 < "../$src"
+ patch -Np1 -i "../$src"
done
}
build() {
-# We only need to build the library in this step, dkms will build the module
-cd "$pkgname-$pkgver/library"
-
-make
+ # We only need to build the library in this step, dkms will build the module
+ cd "$pkgname-$pkgver/library"
+ make
}
package() {
-# Predfine some target folders
-SRCDIR="$pkgdir/usr/src/$pkgname-$pkgver" # This one is needed for dkms
-LIBNAME=lib$pkgname
-
-cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
-install -D -m 755 library/$LIBNAME.so $pkgdir/usr/lib/$LIBNAME.so
+ install -Dm0755 library/lib$pkgname.so "$pkgdir/usr/lib/lib$pkgname.so"
-install -d $SRCDIR
-install -D -m 755 module/* $SRCDIR
+ SRCDIR="$pkgdir/usr/src/$pkgname-$pkgver" # This one is needed for dkms
+ install -d "$SRCDIR"
+ install -Dm0755 module/* "$SRCDIR"
}
diff --git a/evdi.install b/evdi.install
deleted file mode 100644
index 89a76551a680..000000000000
--- a/evdi.install
+++ /dev/null
@@ -1,20 +0,0 @@
-# old version (without -$pkgrel): ${1%%-*}
-# new version (without -$pkgrel): ${2%%-*}
-
-post_install() {
- echo 'DKMS install...'
- dkms install evdi/${1%%-*}
-}
-
-pre_upgrade() {
- pre_remove ${2%%-*}
-}
-
-post_upgrade() {
- post_install ${1%%-*}
-}
-
-pre_remove() {
- echo 'DKMS remove...'
- dkms remove evdi/${1%%-*} --all
-}