summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlusMinus02016-09-16 10:04:41 +0200
committerPlusMinus02016-09-16 10:04:41 +0200
commit2fd119c8a92c4759b0d91d01f6c7299f13ecb89f (patch)
treeee309b160bbb39f8d91226a7d1465c09ce9d3ad1
parent305118d06a35f08fa5f02522b31b5845df96dac5 (diff)
downloadaur-2fd119c8a92c4759b0d91d01f6c7299f13ecb89f.tar.gz
Add sourced to directory for dkms install
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea9af384535e..be004a892ff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,19 +23,21 @@ noextract=()
md5sums=('579889b974e3f1f889bf1dfa47190cea')
build() {
- cd "$pkgname-$pkgver"
+ # We only need to build the library in this step, dmks will build the module
+ cd "$pkgname-$pkgver/library"
make
}
package() {
- cd "$pkgname-$pkgver"
-
+ # Predfine some target folders
+ SRCDIR="$pkgdir/usr/src/$pkgname-$pkgver" # This one is needed for dkms
LIBNAME=lib$pkgname
- install -D -m 755 library/$LIBNAME.so $pkgdir/usr/lib/$LIBNAME/$LIBNAME.so
- install -D -m 755 module/*.o $pkgdir/usr/lib/$LIBNAME
+ cd "$pkgname-$pkgver"
+
+ install -D -m 755 library/$LIBNAME.so $pkgdir/usr/lib/$LIBNAME.so
- install -d $pkgdir/usr/include/$LIBNAME
- install -D -m 755 module/*.h $pkgdir/usr/include/$LIBNAME
+ install -d $SRCDIR
+ install -D -m 755 module/* $SRCDIR
}