summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPusMinus02017-02-06 16:57:43 +0100
committerPusMinus02017-02-06 16:57:43 +0100
commit775922609c3c6c99bf6d2491347cc9e262580dcb (patch)
tree7b0becefe5fbc7eb16a7320e936c855e5c89f9fa
parent75f1a1d72eb333eaee3984a74ee612c6d3a34ec6 (diff)
downloadaur-775922609c3c6c99bf6d2491347cc9e262580dcb.tar.gz
Fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1ec1da40b32..017f5e679f4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Feb 6 13:01:17 UTC 2017
+# Mon Feb 6 15:57:33 UTC 2017
pkgbase = evdi
pkgdesc = A Linux® kernel module that enables management of multiple screens.
pkgver = 1.2.64
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/DisplayLink/evdi
install = evdi.install
changelog = evdi.Changelog
@@ -11,7 +11,7 @@ pkgbase = evdi
arch = x86_64
license = GPL
depends = dkms
- source = evdi-1.2.64-2.tar.gz::https://github.com/DisplayLink/evdi/archive/b7606bccc0cb9484c2845a3e556faf60ed3c0bff.tar.gz
+ source = b7606bccc0cb9484c2845a3e556faf60ed3c0bff.tar.gz::https://github.com/DisplayLink/evdi/archive/b7606bccc0cb9484c2845a3e556faf60ed3c0bff.tar.gz
md5sums = 2f229d85de2aa5c1ba6f168a0728ec9d
pkgname = evdi
diff --git a/PKGBUILD b/PKGBUILD
index abe80fc1af16..3f59a4ba9f39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=evdi
pkgver=1.2.64
-pkgrel=2
+pkgrel=3
pkgdesc="A Linux® kernel module that enables management of multiple screens."
arch=('i686' 'x86_64')
url="https://github.com/DisplayLink/evdi"
@@ -19,26 +19,27 @@ options=()
install=$pkgname.install
changelog=$pkgname.Changelog
#source=($pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/DisplayLink/evdi/archive/v$pkgver.tar.gz)
-source=($pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/DisplayLink/evdi/archive/b7606bccc0cb9484c2845a3e556faf60ed3c0bff.tar.gz)
-md5sums=('2f229d85de2aa5c1ba6f168a0728ec9d')
+source=(b7606bccc0cb9484c2845a3e556faf60ed3c0bff.tar.gz::https://github.com/DisplayLink/evdi/archive/b7606bccc0cb9484c2845a3e556faf60ed3c0bff.tar.gz)
noextract=()
+md5sums=('2f229d85de2aa5c1ba6f168a0728ec9d')
build() {
- # We only need to build the library in this step, dmks will build the module
- cd "$pkgname-$pkgver/library"
+# We only need to build the library in this step, dmks will build the module
+mv evdi-b7606bccc0cb9484c2845a3e556faf60ed3c0bff $pkgname-$pkgver
+cd "$pkgname-$pkgver/library"
- make
+make
}
package() {
- # Predfine some target folders
- SRCDIR="$pkgdir/usr/src/$pkgname-$pkgver-$pkgrel" # This one is needed for dkms
- LIBNAME=lib$pkgname
+# Predfine some target folders
+SRCDIR="$pkgdir/usr/src/$pkgname-$pkgver" # This one is needed for dkms
+LIBNAME=lib$pkgname
+
+cd "$pkgname-$pkgver"
- cd "$pkgname-$pkgver"
+install -D -m 755 library/$LIBNAME.so $pkgdir/usr/lib/$LIBNAME.so
- install -D -m 755 library/$LIBNAME.so $pkgdir/usr/lib/$LIBNAME.so
-
- install -d $SRCDIR
- install -D -m 755 module/* $SRCDIR
+install -d $SRCDIR
+install -D -m 755 module/* $SRCDIR
}