summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Glidic2016-05-28 11:31:10 +0200
committerQuentin Glidic2016-05-28 12:38:12 +0200
commit93002bbc4084637d831a4ec53c82db12f27673c3 (patch)
tree632f041462897b9521760fa4b02525d0d9224558
downloadaur-93002bbc4084637d831a4ec53c82db12f27673c3.tar.gz
eventd: Initial package
Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD73
2 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7c7839a457f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = eventd
+ pkgdesc = A small daemon to act on remote or local events
+ pkgver = 0.18.1
+ pkgrel = 1
+ url = https://www.eventd.org
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ license = MIT
+ makedepends = libxslt
+ makedepends = docbook-xsl
+ depends = avahi
+ depends = cairo>=1.14.0
+ depends = gdk-pixbuf2
+ depends = glib2>=2.40.0
+ depends = glib-networking
+ depends = pango
+ depends = libsystemd
+ depends = libxcb
+ depends = util-linux
+ depends = xcb-util
+ depends = xcb-util-wm
+ optdepends = librsvg: SVG images support
+ options = !strip
+ source = https://www.eventd.org/download/eventd/eventd-0.18.1.tar.xz
+ sha256sums = 40be11f75331c20efc3b6c60010169aad783864cbe1920aecd8204bdef1ec889
+
+pkgname = eventd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd7e067f150f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Quentin Glidic <sardemff7@eventd.org>
+
+pkgname=eventd
+pkgver=0.18.1
+_pkgdir=${pkgname}-${pkgver}
+pkgrel=1
+pkgdesc="A small daemon to act on remote or local events"
+arch=(
+ i686
+ x86_64
+)
+url="https://www.eventd.org"
+license=(
+ GPL3
+ LGPL3
+ MIT
+)
+depends=(
+ avahi
+ 'cairo>=1.14.0'
+ gdk-pixbuf2
+ 'glib2>=2.40.0'
+ glib-networking
+ pango
+ libsystemd
+ libxcb
+ util-linux
+ xcb-util
+ xcb-util-wm
+)
+makedepends=(
+ libxslt
+ docbook-xsl
+)
+optdepends=(
+ 'librsvg: SVG images support'
+)
+options=(
+ !strip
+)
+source=(
+ https://www.eventd.org/download/${pkgname}/${pkgname}-${pkgver}.tar.xz
+)
+sha256sums=(
+ 40be11f75331c20efc3b6c60010169aad783864cbe1920aecd8204bdef1ec889
+)
+
+build() {
+ local params=(
+ --prefix=/usr
+ --enable-systemd
+ --disable-introspection
+ --disable-ssdp
+ --disable-nd-wayland
+ --disable-im
+ --disable-sound
+ )
+
+ cd "${srcdir}"/${_pkgdir}
+ ./configure "${params[@]}"
+
+ make
+}
+
+check() {
+ cd "${srcdir}"/${_pkgdir}
+ make check
+}
+
+package() {
+ cd "${srcdir}"/${_pkgdir}
+ make DESTDIR="${pkgdir}" install
+}