summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLA-MJ2023-05-20 23:39:47 +0200
committerLA-MJ2023-05-20 23:39:47 +0200
commit1e0b6a1ce7da548db1217de9962582b06c0cf2ca (patch)
tree69642cb5117c6b22a94e111121c697d7d42b2d75
parent57dfbec398f89dfc0b43e5916b8ef8875c7afc8e (diff)
downloadaur-1e0b6a1ce7da548db1217de9962582b06c0cf2ca.tar.gz
update to 4.5.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
-rw-r--r--disableUtimeTests.patch20
-rw-r--r--python310.patch65
4 files changed, 19 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b91a776b8c05..769761f6173d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = exfalso
pkgdesc = Music player and music library manager
- pkgver = 4.4.0
- pkgrel = 3
+ pkgver = 4.5.0
+ pkgrel = 1
url = https://quodlibet.readthedocs.io/
arch = any
license = GPL2
@@ -12,19 +12,16 @@ pkgbase = exfalso
makedepends = python-sphinx_rtd_theme
depends = dbus-python
depends = gtk3
+ depends = libsoup
depends = python-cairo
depends = python-feedparser
depends = python-gobject
depends = python-mutagen
- source = https://github.com/quodlibet/quodlibet/releases/download/release-4.4.0/quodlibet-4.4.0.tar.gz
- source = https://github.com/quodlibet/quodlibet/releases/download/release-4.4.0/quodlibet-4.4.0.tar.gz.sig
- source = python310.patch
- source = disableUtimeTests.patch
+ source = https://github.com/quodlibet/quodlibet/releases/download/release-4.5.0/quodlibet-4.5.0.tar.gz
+ source = https://github.com/quodlibet/quodlibet/releases/download/release-4.5.0/quodlibet-4.5.0.tar.gz.sig
validpgpkeys = 0EBF782C5D53F7E5FB02A66746BD761F7A49B0EC
- sha256sums = a03318d2767e4959551763d0a87fad977387af712608fe572714176a24bbf367
+ sha256sums = 301615829f652cbafedb35539237162a58bc1ee71a567d249f7789d9268245bc
sha256sums = SKIP
- sha256sums = ae075d9b5fb88b58b010b76c2d5e3eb40805556d9de92ca6adb8e62d6f052b01
- sha256sums = 6cf7d436a77cd33143ced18f074941dbf7fc1acd461bf5e2ae05681e7da496b6
pkgname = exfalso
optdepends = gst-plugins-bad: Submit Acoustic Fingerprints plugin
diff --git a/PKGBUILD b/PKGBUILD
index 6bb7888e23a1..36635de464c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,27 @@
_pkgbase=quodlibet
pkgname=(exfalso)
-pkgver=4.4.0
-pkgrel=3
+pkgver=4.5.0
+pkgrel=1
pkgdesc="Music player and music library manager"
arch=(any)
url="https://quodlibet.readthedocs.io/"
license=(GPL2)
-depends=(dbus-python gtk3 python-cairo python-feedparser python-gobject python-mutagen)
+depends=(dbus-python gtk3 libsoup python-cairo python-feedparser python-gobject python-mutagen)
makedepends=(python-sphinx_rtd_theme)
# python-raven python-senf are currently vendored
checkdepends=(gst-plugins-base gst-plugins-good python-pytest python-xvfbwrapper)
source=(
"https://github.com/${_pkgbase}/${_pkgbase}/releases/download/release-${pkgver}/${_pkgbase}-${pkgver}.tar.gz"{,.sig}
- python310.patch
- disableUtimeTests.patch
)
-sha256sums=('a03318d2767e4959551763d0a87fad977387af712608fe572714176a24bbf367'
- 'SKIP'
- 'ae075d9b5fb88b58b010b76c2d5e3eb40805556d9de92ca6adb8e62d6f052b01'
- '6cf7d436a77cd33143ced18f074941dbf7fc1acd461bf5e2ae05681e7da496b6')
+sha256sums=('301615829f652cbafedb35539237162a58bc1ee71a567d249f7789d9268245bc'
+ 'SKIP')
validpgpkeys=(0EBF782C5D53F7E5FB02A66746BD761F7A49B0EC) # Christoph Reiter <reiter.christoph@gmail.com>
prepare() {
cd ${_pkgbase}-${pkgver}
# Fix zsh completions dir
sed -e 's|vendor-completions|site-functions|' -i gdist/zsh_completions.py
- patch -p5 < ../python310.patch
- patch -p2 < ../disableUtimeTests.patch
}
build() {
@@ -38,9 +32,13 @@ build() {
check() {
cd ${_pkgbase}-${pkgver}
- export PYTHONPATH="build:${PYTHONPATH}"
+ export PYTHONPATH="${PWD}/build"
# not running useless linter checks
- pytest -v -k 'not TFlake8'
+ # TOperonEdit.test_remove_all: https://github.com/quodlibet/quodlibet/issues/3966
+ # TCoverManager.test_invalid_glob: https://github.com/quodlibet/quodlibet/issues/4021
+ pytest -v --color=yes -k 'not TFlake8' \
+ --deselect tests/test_operon.py::TOperonEdit::test_remove_all \
+ --deselect tests/test_util_cover.py::TCoverManager::test_invalid_glob
}
package_exfalso() {
@@ -50,9 +48,11 @@ package_exfalso() {
'python-musicbrainzngs: MusicBrainz Lookup, MusicBrainz Sync plugins')
conflicts=("${_pkgbase}")
+
cd ${_pkgbase}-${pkgver}
python setup.py install --root="${pkgdir}" --skip-build --optimize=1
+
# Remove Quod Libet
internal_name="io.github.${_pkgbase}.QuodLibet"
rm "${pkgdir}"/usr/bin/${_pkgbase}
diff --git a/disableUtimeTests.patch b/disableUtimeTests.patch
deleted file mode 100644
index d282f43bc571..000000000000
--- a/disableUtimeTests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/quodlibet-4.4.0/tests/test_operon.py.old 2021-12-30 16:58:20.606253261 +0100
-+++ src/quodlibet-4.4.0/tests/test_operon.py 2021-12-30 16:59:13.129298377 +0100
-@@ -357,7 +357,7 @@
- self.check_false(["edit", self.f], False, True)
-
- def test_dry_run(self):
-- if os.name == "nt" or sys.platform == "darwin":
-+ if True:
- return
-
- realitems = lambda s: [(k, s[k]) for k in s.realkeys()]
-@@ -376,7 +376,7 @@
- self.assertEqual(sorted(old_items), sorted(realitems(self.s)))
-
- def test_remove_all(self):
-- if os.name == "nt" or sys.platform == "darwin":
-+ if True:
- return
-
- os.environ["VISUAL"] = "truncate -s 0"
diff --git a/python310.patch b/python310.patch
deleted file mode 100644
index 59699ce60293..000000000000
--- a/python310.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- ./usr/lib/python3.10/site-packages/quodlibet/packages/raven/context.py.old 2021-12-30 15:21:07.624928093 +0100
-+++ ./usr/lib/python3.10/site-packages/quodlibet/packages/raven/context.py 2021-12-30 15:23:39.434095049 +0100
-@@ -7,7 +7,7 @@
- """
- from __future__ import absolute_import
-
--from collections import Mapping, Iterable
-+from collections.abc import Mapping, Iterable
- from threading import local
- from weakref import ref as weakref
-
---- ./usr/lib/python3.10/site-packages/quodlibet/player/gstbe/util.py.old 2021-12-30 15:34:06.933985011 +0100
-+++ ./usr/lib/python3.10/site-packages/quodlibet/player/gstbe/util.py 2021-12-30 15:34:49.063753826 +0100
-@@ -6,7 +6,7 @@
- # the Free Software Foundation; either version 2 of the License, or
- # (at your option) any later version.
-
--import collections
-+from collections import abc
- import subprocess
- from enum import Enum
- from typing import Iterable, Tuple
-@@ -183,7 +183,7 @@
- return pipe, pipeline_desc
-
-
--class TagListWrapper(collections.Mapping):
-+class TagListWrapper(abc.Mapping):
- def __init__(self, taglist, merge=False):
- self._list = taglist
- self._merge = merge
---- ./usr/lib/python3.10/site-packages/quodlibet/util/collection.py.old 2021-12-30 15:20:53.901670066 +0100
-+++ ./usr/lib/python3.10/site-packages/quodlibet/util/collection.py 2021-12-30 15:21:42.868068032 +0100
-@@ -24,7 +24,7 @@
- AudioFile)
- from quodlibet.formats._audio import PEOPLE as _PEOPLE
- from quodlibet.pattern import Pattern
--from collections import Iterable
-+from collections.abc import Iterable
-
- from quodlibet.util import is_windows
- from quodlibet.util.path import escape_filename, unescape_filename, limit_path
---- ./usr/lib/python3.10/site-packages/quodlibet/util/collections.py.old 2021-12-30 15:27:18.032895500 +0100
-+++ ./usr/lib/python3.10/site-packages/quodlibet/util/collections.py 2021-12-30 15:27:58.639339341 +0100
-@@ -9,7 +9,8 @@
-
- from __future__ import absolute_import
-
--from collections import MutableSequence, defaultdict
-+from collections import defaultdict
-+from collections.abc import MutableSequence
-
- from .misc import total_ordering
-
---- ./usr/lib/python3.10/site-packages/quodlibet/util/http.py.old 2021-12-30 15:28:35.722469182 +0100
-+++ ./usr/lib/python3.10/site-packages/quodlibet/util/http.py 2021-12-30 15:28:49.855724960 +0100
-@@ -7,7 +7,7 @@
- # (at your option) any later version.
-
- import json
--from collections import Callable
-+from collections.abc import Callable
- from typing import Optional, Any
-
- from gi.repository import Soup, Gio, GLib, GObject