summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2019-11-15 17:27:20 +0100
committerBruno Pagani2019-11-15 17:27:20 +0100
commit2f356d59f587612ff2dfbc37e80f20fbbd15dcd2 (patch)
tree2eb785ad912f43143422a89b33ae481e04a65d31
parentea545f24d0c97998ed3c3d757e0c97a996096a51 (diff)
downloadaur-2f356d59f587612ff2dfbc37e80f20fbbd15dcd2.tar.gz
Fix build with pacman 5.2
Also cleaned PKGBUILD style
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15e4417de686..c6b13bdf2e7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,7 @@ pkgbase = exfalso
optdepends = kakasi: for "Kana/Kanji Simple Inverter" plugin
optdepends = python-dbus: for "Browse Folders" plugin
optdepends = python-musicbrainzngs: for "MusicBrainz Lookup" plugin
+ conflicts = quodlibet
source = https://github.com/quodlibet/quodlibet/releases/download/release-4.2.1/quodlibet-4.2.1.tar.gz
source = https://github.com/quodlibet/quodlibet/releases/download/release-4.2.1/quodlibet-4.2.1.tar.gz.sig
validpgpkeys = 0EBF782C5D53F7E5FB02A66746BD761F7A49B0EC
diff --git a/PKGBUILD b/PKGBUILD
index 0a23d35c907b..52731942cc66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,19 @@ pkgname=exfalso
pkgver=4.2.1
pkgrel=1
pkgdesc="GTK+ audio tag editor"
-arch=('any')
+arch=(any)
url="https://quodlibet.readthedocs.io/"
-license=('GPL2')
-depends=('gtk3' 'python-mutagen' 'python-gobject' 'python-cairo' 'python-feedparser')
+license=(GPL2)
+depends=(gtk3 python-mutagen python-gobject python-cairo python-feedparser)
optdepends=('gst-plugins-bad: for "Acoustic Fingerprint" plugins'
'gst-plugins-good: for "Replay Gain" plugin'
'kakasi: for "Kana/Kanji Simple Inverter" plugin'
'python-dbus: for "Browse Folders" plugin'
'python-musicbrainzngs: for "MusicBrainz Lookup" plugin')
-conflicts=("${pkgbase}")
+conflicts=("${_pkgbase}")
source=("https://github.com/${_pkgbase}/${_pkgbase}/releases/download/release-${pkgver}/${_pkgbase}-${pkgver}.tar.gz"{,.sig})
-sha256sums=('870a11e685213828733222dcb3d314a90d3b7bdf4757af60954b680c49de392c'
- 'SKIP')
-validpgpkeys=('0EBF782C5D53F7E5FB02A66746BD761F7A49B0EC') # Christoph Reiter
+sha256sums=(870a11e685213828733222dcb3d314a90d3b7bdf4757af60954b680c49de392c SKIP)
+validpgpkeys=(0EBF782C5D53F7E5FB02A66746BD761F7A49B0EC) # Christoph Reiter
build() {
cd ${_pkgbase}-${pkgver}
@@ -27,7 +26,7 @@ build() {
python setup.py build
}
-package_exfalso() {
+package() {
cd ${_pkgbase}-${pkgver}
python setup.py install --root="${pkgdir}" --skip-build --optimize=1
@@ -76,5 +75,3 @@ package_exfalso() {
-o -name "refresh.*" \
\) -delete
}
-
-# vim:set tabstop=4 softtabstop=4 shiftwidth=4 expandtab: