summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2017-04-27 07:02:44 +0200
committeraksr2017-04-27 07:02:44 +0200
commit0e0cc3c18e988b9dbed6909998b29fde695b2b56 (patch)
tree7b060e43098d64861bacece8b3376ef1c3945c5f
downloadaur-exhal-git.tar.gz
Start.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f6230ac8438
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Apr 27 05:02:44 UTC 2017
+pkgbase = exhal-git
+ pkgdesc = Compression and decompression tools for NES, SNES, and Game Boy games by HAL Laboratory
+ pkgver = 1.21b.r53.44affc7
+ pkgrel = 1
+ url = https://github.com/devinacker/exhal
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ source = exhal-git::git+https://github.com/devinacker/exhal.git
+ md5sums = SKIP
+
+pkgname = exhal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a285c335d5ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=exhal-git
+pkgver=1.21b.r53.44affc7
+pkgrel=1
+epoch=
+pkgdesc="Compression and decompression tools for NES, SNES, and Game Boy games by HAL Laboratory"
+arch=('i686' 'x86_64')
+url="https://github.com/devinacker/exhal"
+license=('MIT')
+categories=()
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/devinacker/exhal.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "%s.r%s.%s" "$(git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 exhal $pkgdir/usr/bin/exhal
+ install -Dm755 inhal $pkgdir/usr/bin/inhal
+ install -Dm644 README.txt $pkgdir/usr/share/doc/${pkgname%-*}/README
+ install -Dm644 COPYING.txt $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+}
+