summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Shatunov2016-12-15 03:05:23 +0700
committerSergey Shatunov2016-12-15 03:05:23 +0700
commit7b1a947de330701cf06c5a6588575235a03523c7 (patch)
tree5dfce056e78e1a29e37373cae0fded8ec9056f6c
parent5e8880dcdd7303b7231d51295777ee000e350899 (diff)
downloadaur-7b1a947de330701cf06c5a6588575235a03523c7.tar.gz
Enable outgoing/ingoing proxy support and SMTPUTF8 extension
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--exim.Makefile26
3 files changed, 32 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3cb8a7c8d2a..d1681ff6a9c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = exim-pgsql
pkgdesc = Message Transfer Agent
pkgver = 4.87
- pkgrel = 2
+ pkgrel = 3
url = http://www.exim.org/
install = exim.install
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = exim-pgsql
depends = libldap
depends = libspf2
depends = postgresql-libs
+ depends = libidn
provides = smtp-server
provides = smtp-forwarder
conflicts = smtp-server
@@ -34,7 +35,7 @@ pkgbase = exim-pgsql
md5sums = 2effc2bd47ad2dc010f655c11a1b1173
md5sums = 4874006f0585253ddab027d441009757
md5sums = e18a535218718c5eb394ed5c9296fe06
- md5sums = 1b1602add61e1d7fa9f00b163800619d
+ md5sums = 105ba2791b78639a6c6b50d03617258d
md5sums = 88cf76405367a6ed371d05db1d3c9565
md5sums = be8fdcf7b2d6b6368a21705e69743265
md5sums = 6f5a5c2b0835b33f59d2513cce18c65b
diff --git a/PKGBUILD b/PKGBUILD
index 4e36c1ec27d4..97957378c764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,14 @@
_pkgname=exim
pkgname=${_pkgname}-pgsql
pkgver=4.87
-pkgrel=2
+pkgrel=3
pkgdesc='Message Transfer Agent'
arch=('x86_64' 'i686')
url='http://www.exim.org/'
license=('GPL')
backup=(etc/mail/aliases etc/mail/exim.conf etc/logrotate.d/exim)
install=exim.install
-depends=('gdbm' 'pcre' 'pam' 'openssl' 'libldap' 'libspf2' 'postgresql-libs')
+depends=('gdbm' 'pcre' 'pam' 'openssl' 'libldap' 'libspf2' 'postgresql-libs' 'libidn')
provides=('smtp-server' 'smtp-forwarder')
conflicts=('smtp-server' 'smtp-forwarder')
options=('!makeflags')
@@ -32,7 +32,7 @@ source=(ftp://ftp.exim.org/pub/exim/exim4/exim-$pkgver.tar.bz2
md5sums=('2effc2bd47ad2dc010f655c11a1b1173'
'4874006f0585253ddab027d441009757'
'e18a535218718c5eb394ed5c9296fe06'
- '1b1602add61e1d7fa9f00b163800619d'
+ '105ba2791b78639a6c6b50d03617258d'
'88cf76405367a6ed371d05db1d3c9565'
'be8fdcf7b2d6b6368a21705e69743265'
'6f5a5c2b0835b33f59d2513cce18c65b'
diff --git a/exim.Makefile b/exim.Makefile
index 9626e873af6d..8e7b79106283 100644
--- a/exim.Makefile
+++ b/exim.Makefile
@@ -816,6 +816,32 @@ SUPPORT_PAM=yes
#------------------------------------------------------------------------------
+# Proxying.
+#
+# If you may want to use outbound (client-side) proxying, using Socks5,
+# uncomment the line below.
+
+SUPPORT_SOCKS=yes
+
+# If you may want to use inbound (server-side) proxying, using Proxy Protocol,
+# uncomment the line below.
+
+SUPPORT_PROXY=yes
+
+
+#------------------------------------------------------------------------------
+# Internationalisation.
+#
+# Uncomment the following to include Internationalisation features. This is the
+# SMTPUTF8 ESMTP extension, and associated facilities for handling UTF8 domain
+# and localparts, per RFCs 5890, 6530 and 6533.
+# You need to have the IDN library installed.
+
+SUPPORT_I18N=yes
+LDFLAGS += -lidn
+
+
+#------------------------------------------------------------------------------
# Support for authentication via Radius is also available. The Exim support,
# which is intended for use in conjunction with the SMTP AUTH facilities,
# is included only when requested by setting the following parameter to the