summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2015-06-11 09:00:22 -0700
committerJonathan Yantis2015-06-11 09:00:22 -0700
commitbb84f24fee0e24acabac2f385c0d968f34eabd2f (patch)
tree63ab3a6f56e37d4ef8f99130f5edc82d8f36585e
downloadaur-bb84f24fee0e24acabac2f385c0d968f34eabd2f.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD57
-rwxr-xr-xexo-git.install11
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25e653a5a7d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = exo-git
+ pkgdesc = Extensions to Xfce by os-cillation.
+ pkgver = 0.10.6.r1635.ce731c3
+ pkgrel = 2
+ epoch = 1
+ url = http://git.xfce.org/xfce/exo/tree/README
+ install = exo-git.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-git
+ license = GPL2
+ license = LGPL2.1
+ makedepends = xfce4-dev-tools
+ makedepends = git
+ makedepends = pkgconfig
+ makedepends = libnotify
+ makedepends = perl-uri
+ makedepends = pygtk>=2.13
+ depends = libxfce4util
+ depends = gtk2>=2.18.6-1
+ depends = glib2>=2.22.4-1
+ depends = hicolor-icon-theme
+ depends = libxfce4ui
+ depends = libsm
+ optdepends = libnotify: enables notification support
+ optdepends = perl: enables mail-compose helper script
+ provides = exo
+ conflicts = exo
+ options = !libtool
+ source = git://git.xfce.org/xfce/exo
+ md5sums = SKIP
+
+pkgname = exo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23c79bcb2992
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer : jyantis <yantis@yantis.net>
+# Contributor: Diego Principe <cdprincipeat gmaildot com>
+# Contributor: Jan Jezek <honzin.jezek@gmail.com>
+# Contributor: Berseker <berseker86 at gmail dot com>
+
+pkgname=exo-git
+pkgver=0.10.6.r1635.ce731c3
+pkgrel=2
+pkgdesc="Extensions to Xfce by os-cillation."
+arch=(i686 x86_64)
+license=('GPL2' 'LGPL2.1')
+url="http://git.xfce.org/xfce/exo/tree/README"
+groups=('xfce4-git')
+depends=('libxfce4util' 'gtk2>=2.18.6-1' 'glib2>=2.22.4-1' 'hicolor-icon-theme' 'libxfce4ui' 'libsm')
+makedepends=('xfce4-dev-tools' 'git' 'pkgconfig' 'libnotify' 'perl-uri' 'pygtk>=2.13')
+optdepends=('libnotify: enables notification support' 'perl: enables mail-compose helper script')
+conflicts=('exo')
+provides=('exo')
+source=('git://git.xfce.org/xfce/exo')
+options=('!libtool')
+install=$pkgname.install
+md5sums=('SKIP')
+epoch=1
+
+pkgver(){
+ cd exo
+ _majorversion=$(grep -F "m4_define([libexo_version_major]" configure.ac.in | awk 'BEGIN {FS = "["} {print $3}' | sed -r 's/(\[|\])//g' | sed -r 's/(\(|\))//g')
+ _minorversion=$(grep -F "m4_define([libexo_version_minor]" configure.ac.in | awk 'BEGIN {FS = "["} {print $3}' | sed -r 's/(\[|\])//g' | sed -r 's/(\(|\))//g')
+ _microversion=$(grep -F "m4_define([libexo_version_micro]" configure.ac.in | awk 'BEGIN {FS = "["} {print $3}' | sed -r 's/(\[|\])//g' | sed -r 's/(\(|\))//g')
+
+ printf "%s." "$_majorversion"
+ printf "%s." "$_minorversion"
+ printf "%s." "$_microversion"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/exo
+
+ # Python 2 fix
+ export PYTHON=python2
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gtk-doc \
+ --disable-debug
+ make
+}
+
+package() {
+ cd $srcdir/exo
+ make DESTDIR=$pkgdir install
+}
diff --git a/exo-git.install b/exo-git.install
new file mode 100755
index 000000000000..21b79d2d44de
--- /dev/null
+++ b/exo-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}