summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Mikhayloff2018-08-17 14:58:03 +0300
committerRoman Mikhayloff2018-08-17 14:58:03 +0300
commitc23afd2426ad655fb491fc0560cc8763ce7736ab (patch)
tree612e0f6f3d4ef7b560c9147a53575f9591ed32e2
parent28246e9bd0ac10b62f5bd4aeb46fba0888fbca5e (diff)
downloadaur-expertguide-git.tar.gz
Fix building
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dae0add23c28..6c78b721bd77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = expertguide-git
pkgdesc = Expert Guide, a Norton Guide reader for GNU/Linux
- pkgver = 1.01.15.g6ff2aa0
+ pkgver = v1.02.r0.g3c7e6fd
pkgrel = 1
url = http://www.davep.org/norton-guides/
arch = i686
@@ -9,7 +9,8 @@ pkgbase = expertguide-git
makedepends = git
depends = slang
provides = expertguide
- conflicts = expertguide eg
+ conflicts = expertguide
+ conflicts = eg
source = git+https://github.com/davep/eg.git
source = build.patch
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4faccd296704..b1d93315ba99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=expertguide-git
_gitname=eg
-pkgver=1.01.15.g6ff2aa0
+pkgver=v1.02.r0.g3c7e6fd
pkgrel=1
pkgdesc="Expert Guide, a Norton Guide reader for GNU/Linux"
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ license=('GPL')
depends=('slang')
makedepends=('git')
provides=('expertguide')
-conflicts=("expertguide eg")
+conflicts=('expertguide' 'eg')
source=('git+https://github.com/davep/eg.git'
'build.patch')
sha1sums=('SKIP'
@@ -19,7 +19,7 @@ sha1sums=('SKIP'
pkgver() {
cd "${srcdir}/${_gitname}"
- git describe --tags | sed -e 's/eg-v//;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {