summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2022-05-21 17:36:08 +0200
committerJoan Bruguera2022-05-21 17:36:08 +0200
commit06caaa2ef5ba4016c09d6987e7bc416478bda37f (patch)
treea134b6ee3e83dfc71ea3cc3a289e111424e006c4
parenta1d4e1d69a25af1e4b3f877d60ff164c326137f2 (diff)
downloadaur-06caaa2ef5ba4016c09d6987e7bc416478bda37f.tar.gz
Autodetect correct MPI lib path after change in Arch package.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c82037a84b8f..407b6aa384c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = extrae
pkgdesc = Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).
pkgver = 4.0.1.20220513
- pkgrel = 2
+ pkgrel = 3
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 938ec18555cb..53ef0aafba7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='extrae'
pkgdesc='Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).'
pkgver='4.0.1.20220513'
-pkgrel='2'
+pkgrel='3'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
@@ -31,6 +31,10 @@ prepare() {
build() {
cd "$srcdir/$pkgname-${pkgver%.*}"
+ # OpenMPI library path changed between openmpi 4.1.2-1 and 4.1.3-1
+ # Autodetect which one it is to smoothen transition
+ [ -e /usr/lib/openmpi/libmpi.so ] && MPILIBPATH=/usr/lib/openmpi || MPILIBPATH=/usr/lib
+
# NOTE: The following optional features are NOT enabled:
# * Automatic instrumentation (with dyninst)
# * CUDA support
@@ -44,7 +48,7 @@ build() {
./configure \
--prefix=/usr \
--with-mpi=/usr \
- --with-mpi-libs=/usr/lib/openmpi \
+ --with-mpi-libs="$MPILIBPATH" \
--with-mpi-headers=/usr/include/openmpi \
--with-unwind=/usr \
--with-unwind-headers=/usr/include \