summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-22 17:31:35 +0100
committerJoan Bruguera2019-03-22 17:31:35 +0100
commit1b99baf15b43a98e8fe98baedf48fc1e8050f93a (patch)
treeeb107841f062876576dde8da9092aa886e0a27ab
parent5186110ebb88ae6aeb358f5b69abbb2e1ba7f652 (diff)
downloadaur-1b99baf15b43a98e8fe98baedf48fc1e8050f93a.tar.gz
Lint and uniformize BSC package files.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD39
2 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 983c0d34610e..b8ba8fa0a04d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = extrae
pkgdesc = Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).
pkgver = 3.6.1
- pkgrel = 2
+ pkgrel = 3
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
@@ -9,6 +9,8 @@ pkgbase = extrae
depends = openmpi
depends = libunwind
depends = papi
+ depends = libxml2
+ depends = zlib
source = https://ftp.tools.bsc.es/extrae/extrae-3.6.1-src.tar.bz2
sha512sums = e88435364c31e6de051965a2f23c49be8fdb2afe7542a962c23a35ced3520cfdec308823c4a28f8276ee30eab34708d7e4e7ee8f412740a37e1252d85ea8b356
diff --git a/PKGBUILD b/PKGBUILD
index 9d21bc2d3efe..8ef06651d4e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,34 @@
pkgname='extrae'
pkgdesc='Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).'
pkgver='3.6.1'
-pkgrel='2'
+pkgrel='3'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPLv2.1')
-depends=(openmpi libunwind papi)
+depends=(openmpi libunwind papi libxml2 zlib)
source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2")
sha512sums=(e88435364c31e6de051965a2f23c49be8fdb2afe7542a962c23a35ced3520cfdec308823c4a28f8276ee30eab34708d7e4e7ee8f412740a37e1252d85ea8b356)
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
-}
-
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
- ./configure \
- --prefix=/usr \
- --with-mpi=/usr \
- --with-mpi-libs=/usr/lib/openmpi \
- --with-mpi-headers=/usr/include/openmpi \
- --with-unwind=/usr \
- --with-unwind-headers=/usr/include \
- --with-unwind-libs=/usr/lib \
- --without-dyninst \
- --with-papi=/usr \
- --with-papi-headers=/usr/include \
- --with-papi-libs=/usr/lib \
+ # NOTE: The following optional features are NOT enabled:
+ # * Automatic instrumentation (with dyninst)
+ # * CUDA support
+ # * OpenCL support
+ # * LaTeX documentation
+ ./configure \
+ --prefix=/usr \
+ --with-mpi=/usr \
+ --with-unwind=/usr \
+ --with-papi=/usr \
+ --without-dyninst
- make
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" install
} \ No newline at end of file