summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2020-03-03 22:25:43 +0100
committerJoan Bruguera2020-03-03 22:25:43 +0100
commit3d4915a479aadd11a5ff50a488b59031f1febf45 (patch)
treea309e9ed7e99928c943947e375428de64cf1d302
parent86d13044130a40a02e884fe9950c509e0f791793 (diff)
downloadaur-3d4915a479aadd11a5ff50a488b59031f1febf45.tar.gz
Buildfix due to binutils 2.34 update.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--extrae-Fix-up-bfd_get_section_-macros-due-to-binutils-2.34.patch57
3 files changed, 68 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 074c906f2b70..1b9076227601 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = extrae
pkgdesc = Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).
pkgver = 3.7.1.20200129
- pkgrel = 2
+ pkgrel = 3
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
@@ -15,9 +15,11 @@ pkgbase = extrae
source = https://ftp.tools.bsc.es/extrae/extrae-3.7.1-src.tar.bz2
source = extrae-issue-27-fix-pie-address-translation.patch
source = extrae-Fix-references-to-the-build-directory.patch
+ source = extrae-Fix-up-bfd_get_section_-macros-due-to-binutils-2.34.patch
sha512sums = b1a72a0a813de179946b83cea0a64c918654e6a6a2211e097b306dda13d69b4a8707d0390c225418fe4e92750cc7822a258c247e2472aab2415deecb50a4f53c
sha512sums = 3b0fae157fcc6e85be3a5565c2ea3abe8bf35e130de96435a93ba7b3f4b6c30df8982823d36c494633a2c16671664112558393faeead05226b96aa521bb14fba
sha512sums = 1f4e5ab8b375cd456c3f4d0356e33f99d3fd49152b3147a0fdc5317368b1df11bdbda809720c38959c698e885615e961d37a87d3ad6b6b85a3a2caf0c1117db1
+ sha512sums = 0f622819dd204fb77f9dc6f5ca612b44296b783c347d37e845d09b5c447214e2537fa6608367dba4c8e928c81e640b88daf019ea15c7ca83bb9308899e997b8c
pkgname = extrae
diff --git a/PKGBUILD b/PKGBUILD
index e8624b15ec72..326cdd1522a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,27 @@
pkgname='extrae'
pkgdesc='Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).'
pkgver='3.7.1.20200129'
-pkgrel='2'
+pkgrel='3'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
depends=(openmpi libunwind papi libxml2 zlib python)
source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2"
extrae-issue-27-fix-pie-address-translation.patch
- extrae-Fix-references-to-the-build-directory.patch)
+ extrae-Fix-references-to-the-build-directory.patch
+ extrae-Fix-up-bfd_get_section_-macros-due-to-binutils-2.34.patch)
sha512sums=(b1a72a0a813de179946b83cea0a64c918654e6a6a2211e097b306dda13d69b4a8707d0390c225418fe4e92750cc7822a258c247e2472aab2415deecb50a4f53c
3b0fae157fcc6e85be3a5565c2ea3abe8bf35e130de96435a93ba7b3f4b6c30df8982823d36c494633a2c16671664112558393faeead05226b96aa521bb14fba
- 1f4e5ab8b375cd456c3f4d0356e33f99d3fd49152b3147a0fdc5317368b1df11bdbda809720c38959c698e885615e961d37a87d3ad6b6b85a3a2caf0c1117db1)
+ 1f4e5ab8b375cd456c3f4d0356e33f99d3fd49152b3147a0fdc5317368b1df11bdbda809720c38959c698e885615e961d37a87d3ad6b6b85a3a2caf0c1117db1
+ 0f622819dd204fb77f9dc6f5ca612b44296b783c347d37e845d09b5c447214e2537fa6608367dba4c8e928c81e640b88daf019ea15c7ca83bb9308899e997b8c)
prepare() {
cd "$srcdir/$pkgname-${pkgver%.*}"
+ # Upstream issue: https://github.com/bsc-performance-tools/extrae/issues/27
patch -Np1 -i "$srcdir/extrae-issue-27-fix-pie-address-translation.patch"
patch -Np1 -i "$srcdir/extrae-Fix-references-to-the-build-directory.patch"
+ patch -Np1 -i "$srcdir/extrae-Fix-up-bfd_get_section_-macros-due-to-binutils-2.34.patch"
autoreconf -i -f
}
@@ -51,4 +55,4 @@ package() {
cd "$srcdir/$pkgname-${pkgver%.*}"
make DESTDIR="$pkgdir/" install
-} \ No newline at end of file
+}
diff --git a/extrae-Fix-up-bfd_get_section_-macros-due-to-binutils-2.34.patch b/extrae-Fix-up-bfd_get_section_-macros-due-to-binutils-2.34.patch
new file mode 100644
index 000000000000..65357b12ad2a
--- /dev/null
+++ b/extrae-Fix-up-bfd_get_section_-macros-due-to-binutils-2.34.patch
@@ -0,0 +1,57 @@
+From 2564787ea16dbcfc1ebcccbebe17a2e85d433574 Mon Sep 17 00:00:00 2001
+From: Joan Bruguera <joanbrugueram@gmail.com>
+Date: Tue, 3 Mar 2020 22:20:30 +0100
+Subject: [PATCH] Fix up bfd_get_section_* macros due to binutils 2.34 update.
+ See
+ https://wiki.gentoo.org/wiki/Binutils_2.34_porting_notes/undefined_reference_to_bfd_get_section_*
+ for more details.
+
+---
+ src/merger/common/bfd_manager.c | 16 +++-------------
+ 1 file changed, 3 insertions(+), 13 deletions(-)
+
+diff --git a/src/merger/common/bfd_manager.c b/src/merger/common/bfd_manager.c
+index 86777b7..79d49d0 100644
+--- a/src/merger/common/bfd_manager.c
++++ b/src/merger/common/bfd_manager.c
+@@ -233,34 +233,24 @@ asymbol **BFDmanager_getDefaultSymbols (void)
+ */
+ static void BFDmanager_findAddressInSection (bfd * abfd, asection * section, PTR data)
+ {
+-#if HAVE_BFD_GET_SECTION_SIZE || HAVE_BFD_GET_SECTION_SIZE_BEFORE_RELOC
+ bfd_size_type size;
+-#endif
+ bfd_vma vma;
+ BFDmanager_symbolInfo_t *symdata = (BFDmanager_symbolInfo_t*) data;
+
+ if (symdata->found)
+ return;
+
+- if ((bfd_get_section_flags (abfd, section) & SEC_ALLOC) == 0)
++ if ((bfd_section_flags (section) & SEC_ALLOC) == 0)
+ return;
+
+- vma = bfd_get_section_vma (abfd, section);;
++ vma = bfd_section_vma (section);;
+
+ if (symdata->pc < vma)
+ return;
+
+-#if HAVE_BFD_GET_SECTION_SIZE
+- size = bfd_get_section_size (section);
+- if (symdata->pc >= vma + size)
+- return;
+-#elif HAVE_BFD_GET_SECTION_SIZE_BEFORE_RELOC
+- size = bfd_get_section_size_before_reloc (section);
++ size = bfd_section_size (section);
+ if (symdata->pc >= vma + size)
+ return;
+-#else
+- /* Do nothing? */
+-#endif
+
+ symdata->found = bfd_find_nearest_line (abfd, section, symdata->symbols,
+ symdata->pc - vma, &symdata->filename, &symdata->function,
+--
+2.25.1
+