summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2015-12-03 11:22:07 +1100
committerMatthew Gamble2015-12-03 11:22:07 +1100
commit4bc5dd591c3fa2eeeec85b22f9fa10b6de42bdd6 (patch)
treec2a0416b8b08a4d82a8062a49deaf3eb05676396
downloadaur-f.tar.gz
Initial commit of PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e35f6924a4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = f
+ pkgdesc = Stress-free wrapper around find.
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = https://github.com/knu/g
+ arch = any
+ license = BSD-2-Clause
+ depends = bash
+ source = https://github.com/knu/g/archive/v0.5.4.tar.gz
+ sha256sums = 8d01159f45fed02c6f06ecc10f37b8f818c63db4ed3da15e19e26eb029b36938
+
+pkgname = f
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffa0405277b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Matthew Gamble
+
+pkgname=f
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Stress-free wrapper around find."
+arch=('any')
+url='https://github.com/knu/g'
+license=('BSD-2-Clause')
+depends=('bash')
+source=("https://github.com/knu/g/archive/v${pkgver}.tar.gz")
+sha256sums=('8d01159f45fed02c6f06ecc10f37b8f818c63db4ed3da15e19e26eb029b36938')
+
+package() {
+ cd "g-$pkgver"
+ install -Dm755 f "${pkgdir}/usr/bin/f"
+ mkdir -p "${pkgdir}/usr/share/licenses/f"
+ sed -n 5,28p f | sed -e 's/^..//' | sed -e 's/^#//' > "${pkgdir}/usr/share/licenses/f/LICENSE"
+}