summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-11 08:31:49 +0300
committerDimitris Kiziridis2020-05-11 08:31:49 +0300
commit83fe53aca28cdaa87e3a5010c9b58f342d2fa505 (patch)
treef5a75397ea0a6d128cb7d4a5e1379ee1d4dea0c7
parentd2e7c6587c07aa1b677d62d9dbaee1db50fb042d (diff)
downloadaur-fac-bin.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1067e8e2710..e7ddbb945b95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,8 +6,8 @@ pkgbase = fac-bin
arch = x86_64
license = MIT
provides = fac
- source = https://github.com/mkchoi212/fac/releases/download/v2.0.0/fac_2.0.0_linux_amd64.tar.gz
- md5sums = cd1d0959d3276bb86c776658f005c551
+ source = fac-bin-2.0.0.tar.gz::https://github.com/mkchoi212/fac/releases/download/v2.0.0/fac_2.0.0_linux_amd64.tar.gz
+ sha256sums = 91a58e84e0098a1eee45af950ee5cc80d30c083e2ab24cdbe79dd6be514775d9
pkgname = fac-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5d9196a08e25..21c74e171b3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,11 @@ arch=('x86_64')
url="https://github.com/mkchoi212/fac"
license=('MIT')
provides=('fac')
-source=("https://github.com/mkchoi212/fac/releases/download/v${pkgver}/fac_${pkgver}_linux_amd64.tar.gz")
-md5sums=('cd1d0959d3276bb86c776658f005c551')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mkchoi212/fac/releases/download/v${pkgver}/fac_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('91a58e84e0098a1eee45af950ee5cc80d30c083e2ab24cdbe79dd6be514775d9')
package() {
- install -Dm755 "${srcdir}"/fac "${pkgdir}/usr/bin/fac"
- install -Dm644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/fac/LICENSE"
+ install -Dm755 "${srcdir}"/fac "${pkgdir}/usr/bin/fac"
+ install -Dm644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file