summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2016-03-24 01:49:33 +0100
committerNarrat2016-03-24 01:49:33 +0100
commit4dcd2c8b0b2581751ab125ab8c55b3aeee502e66 (patch)
treecbe4f5bde1bccca5c04573562db963258d074536
parente8cf174e2492bdd26c8a44f61b1df873eb17ff47 (diff)
downloadaur-fasd-git.tar.gz
Small updates
No need to kill the .git folder, as it won't be copied into pkgdir. Different pkgver and removal of epoch. Users need to take care themselves in getting the most recent version. Changing the URL to the main repo
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ab3acab5a80..5bc108294bdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 00:49:22 UTC 2016
pkgbase = fasd-git
pkgdesc = Command-line productivity booster, offers quick access to files and directories
- pkgver = 1.0.1.r300.61ce53b
- pkgrel = 2
- epoch = 1
- url = https://github.com/Neki/fasd
+ pkgver = 1.0.1.r7.g90b531a
+ pkgrel = 1
+ url = https://github.com/clvv/fasd
install = fasd-git.install
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 458f2d461506..c131c3d5c6ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: jyantis <yantis@yantis.net>
+# Contributor: jyantis <yantis@yantis.net>
# Contributor: Erik Johnson <palehose at gmail dot com>
-pkgname=fasd-git
-pkgver=1.0.1.r300.61ce53b
-pkgrel=2
+_pkgname=fasd
+pkgname=${_pkgname}-git
+pkgver=1.0.1.r7.g90b531a
+pkgrel=1
pkgdesc='Command-line productivity booster, offers quick access to files and directories'
arch=('any')
-url='https://github.com/Neki/fasd'
+url='https://github.com/clvv/fasd'
license=('MIT')
source=('git+https://github.com/clvv/fasd.git' 'fasd-git.install')
install="fasd-git.install"
@@ -15,28 +16,22 @@ depends=('bash')
makedepends=('git')
provides=('fasd')
conflicts=('fasd')
-epoch=1
+
pkgver() {
- cd fasd
- _version=$(grep -F version fasd | awk -F\" '{print $4}')
- printf "%s.r%s.%s" "${_version}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd fasd
+ cd "$_pkgname"
- # We don't need anything related to git in the package
- rm -rf .git*
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
# Install License
- # MIT/X11 license
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
# Install Documentation
install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
-
- make DESTDIR="${pkgdir}" PREFIX=/usr install
}
# vim:set ts=2 sw=2 et: