summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2024-04-27 11:25:53 +0200
committerFabioLolix2024-04-27 11:25:53 +0200
commitbd4539211ff284db2176fba821acf66ca718e8b9 (patch)
tree4ad52808b9e2f9f2e96af50cfbaa70a35a35171f
parent067bcf970fb8e5198c7bd3cab52b194b10f24941 (diff)
downloadaur-fastfetch-git.tar.gz
revision
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD134
-rwxr-xr-xbumpVersion.sh12
3 files changed, 79 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ca2b5d4fb1b..df45bf170a9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,62 +1,58 @@
pkgbase = fastfetch-git
pkgdesc = Like neofetch, but much faster because written in c
- pkgver = 1.9.1.r25.gb0c1925
- pkgrel = 1
- url = https://github.com/LinusDierheimer/fastfetch
+ pkgver = 2.10.2.r14.g74c89cc0
+ pkgrel = 2
+ url = https://github.com/fastfetch-cli/fastfetch
arch = x86_64
arch = i686
arch = pentium4
- arch = armv5
- arch = armv6h
arch = armv7h
arch = aarch64
arch = riscv64
license = MIT
- makedepends = git
- makedepends = cmake
makedepends = chafa
+ makedepends = cmake
makedepends = dbus
makedepends = dconf
- makedepends = glib2
+ makedepends = ddcutil
+ makedepends = directx-headers
+ makedepends = git
makedepends = imagemagick
makedepends = libnm
makedepends = libpulse
- makedepends = libx11
makedepends = libxcb
makedepends = libxrandr
makedepends = mesa
makedepends = ocl-icd
makedepends = opencl-headers
- makedepends = pciutils
makedepends = vulkan-headers
makedepends = vulkan-icd-loader
makedepends = wayland
makedepends = xfconf
makedepends = zlib
depends = glibc
+ depends = gcc-libs
+ depends = yyjson
optdepends = chafa: Image output as ascii art
- optdepends = dbus: Bluetooth, Media & Player modules
- optdepends = dconf: Output for values that are only stored in DConf
+ optdepends = dbus: Bluetooth, Player & Media detection
+ optdepends = dconf: Needed for values that are only stored in DConf + Fallback for GSettings
+ optdepends = ddcutil: Brightness detection of external displays
+ optdepends = directx-headers: GPU detection in WSL
optdepends = glib2: Output for values that are only stored in GSettings
optdepends = imagemagick: Image output using sixel or kitty graphics protocol
- optdepends = libdrm: Improved AMD GPU output
- optdepends = libnm: Better wifi support
- optdepends = libpulse: Sound module
- optdepends = libx11: Improved X11 support (resolution)
- optdepends = libxcb: Improved X11 support (resolution + multi monitor)
- optdepends = libxrandr: Improved X11 support (resolution + multi monitor)
- optdepends = mesa: OpenGL module
- optdepends = nix: self contained nix package count
+ optdepends = libnm: Wifi detection
+ optdepends = libpulse: Sound detection
+ optdepends = mesa: Needed by the OpenGL module for gl context creation.
+ optdepends = libxrandr: Multi monitor support
optdepends = ocl-icd: OpenCL module
- optdepends = pciutils: GPU module
- optdepends = vulkan-icd-loader: Vulkan module & GPU module fallback
- optdepends = wayland: Improved Wayland support (resolution + multi monitor)
- optdepends = xfconf: XFWM theme + xfce-terminal font
+ optdepends = hwdata: GPU output
+ optdepends = vulkan-icd-loader: Vulkan module & fallback for GPU output
+ optdepends = xfconf: Needed for XFWM theme and XFCE Terminal font
optdepends = zlib: Faster image output when using kitty graphics protocol
+ optdepends = libdrm: Displays detection
provides = fastfetch
conflicts = fastfetch
- backup = etc/fastfetch/config.conf
- source = fastfetch-git::git+https://github.com/LinusDierheimer/fastfetch.git#branch=dev
+ source = git+https://github.com/fastfetch-cli/fastfetch.git#branch=dev
sha256sums = SKIP
pkgname = fastfetch-git
diff --git a/PKGBUILD b/PKGBUILD
index 06fb6e8dadaf..7f4cb8738764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,103 +1,83 @@
-# Maintainer: Linus Dierheimer <Linus@Dierheimer.de>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Linus Dierheimer <Linus@Dierheimer.de>
pkgname=fastfetch-git
-pkgver=1.9.1.r25.gb0c1925
-pkgrel=1
+pkgver=2.10.2.r14.g74c89cc0
+pkgrel=2
pkgdesc="Like neofetch, but much faster because written in c"
-arch=("x86_64" "i686" "pentium4" "armv5" "armv6h" "armv7h" "aarch64" "riscv64")
-url="https://github.com/LinusDierheimer/fastfetch"
-license=("MIT")
-
-depends=(
- "glibc"
-)
+arch=(x86_64 i686 pentium4 armv7h aarch64 riscv64)
+url="https://github.com/fastfetch-cli/fastfetch"
+license=(MIT)
+depends=(glibc gcc-libs yyjson)
makedepends=(
- "git"
- "cmake"
- "chafa"
- "dbus"
- "dconf"
- "glib2"
- "imagemagick"
- "libnm"
- "libpulse"
- "libx11"
- "libxcb"
- "libxrandr"
- "mesa"
- "ocl-icd"
- "opencl-headers"
- "pciutils"
- "vulkan-headers"
- "vulkan-icd-loader"
- "wayland"
- "xfconf"
- "zlib"
+ chafa
+ cmake
+ dbus
+ dconf
+ ddcutil
+ directx-headers
+ git
+ imagemagick
+ libnm
+ libpulse
+ libxcb
+ libxrandr
+ mesa
+ ocl-icd
+ opencl-headers
+ vulkan-headers
+ vulkan-icd-loader
+ wayland
+ xfconf
+ zlib
)
optdepends=(
- "chafa: Image output as ascii art"
- "dbus: Bluetooth, Media & Player modules"
- "dconf: Output for values that are only stored in DConf"
- "glib2: Output for values that are only stored in GSettings"
- "imagemagick: Image output using sixel or kitty graphics protocol"
- "libdrm: Improved AMD GPU output"
- "libnm: Better wifi support"
- "libpulse: Sound module"
- "libx11: Improved X11 support (resolution)"
- "libxcb: Improved X11 support (resolution + multi monitor)"
- "libxrandr: Improved X11 support (resolution + multi monitor)"
- "mesa: OpenGL module"
- "nix: self contained nix package count"
- "ocl-icd: OpenCL module"
- "pciutils: GPU module"
- "vulkan-icd-loader: Vulkan module & GPU module fallback"
- "wayland: Improved Wayland support (resolution + multi monitor)"
- "xfconf: XFWM theme + xfce-terminal font"
- "zlib: Faster image output when using kitty graphics protocol"
-)
-
-_provides_and_conflicts=(
- "fastfetch"
+ 'chafa: Image output as ascii art'
+ 'dbus: Bluetooth, Player & Media detection'
+ 'dconf: Needed for values that are only stored in DConf + Fallback for GSettings'
+ 'ddcutil: Brightness detection of external displays'
+ 'directx-headers: GPU detection in WSL'
+ 'glib2: Output for values that are only stored in GSettings'
+ 'imagemagick: Image output using sixel or kitty graphics protocol'
+ 'libnm: Wifi detection'
+ 'libpulse: Sound detection'
+ 'mesa: Needed by the OpenGL module for gl context creation.'
+ 'libxrandr: Multi monitor support'
+ 'ocl-icd: OpenCL module'
+ 'hwdata: GPU output'
+ 'vulkan-icd-loader: Vulkan module & fallback for GPU output'
+ 'xfconf: Needed for XFWM theme and XFCE Terminal font'
+ 'zlib: Faster image output when using kitty graphics protocol'
+ 'libdrm: Displays detection'
)
-provides=("${_provides_and_conflicts[@]}")
-conflicts=("${_provides_and_conflicts[@]}")
-
-_src_dir="${pkgname}"
-source=("${_src_dir}::git+https://github.com/LinusDierheimer/fastfetch.git#branch=dev")
+provides=(fastfetch)
+conflicts=(fastfetch)
+source=("git+https://github.com/fastfetch-cli/fastfetch.git#branch=dev")
sha256sums=("SKIP")
-backup=("etc/fastfetch/config.conf")
-
-_build_dir="build"
-
pkgver() {
- cd "${_src_dir}"
+ cd fastfetch
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cmake \
- -B "${_build_dir}" \
- -S "${_src_dir}" \
- -DCMAKE_BUILD_TYPE='RelWithDebInfo' \
+ cmake -B build -S "fastfetch" -Wno-dev \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_TESTS='ON' \
+ -DBUILD_TESTS=ON \
-DENABLE_SQLITE3=OFF \
-DENABLE_RPM=OFF \
-DENABLE_IMAGEMAGICK6=OFF \
- -DENABLE_LIBCJSON=OFF \
- -Wno-dev
+ -DENABLE_SYSTEM_YYJSON=ON \
- cmake \
- --build "${_build_dir}"
+ cmake --build build
}
check() {
- ctest --test-dir "${_build_dir}" --output-on-failure
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="${pkgdir}" \
- cmake \
- --install "${_build_dir}"
+ DESTDIR="${pkgdir}" cmake --install build
+ install -D fastfetch/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
diff --git a/bumpVersion.sh b/bumpVersion.sh
deleted file mode 100755
index 4050e00019f2..000000000000
--- a/bumpVersion.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-makepkg -f
-
-version=0
-cd "fastfetch/"
-version="$(git rev-list --count HEAD)"
-cd ..
-
-makepkg --printsrcinfo > .SRCINFO
-
-git add .
-git commit -m "bumped version to r${version}"
-git push