summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoirscape2021-06-23 15:20:45 +0200
committernoirscape2021-06-23 15:21:37 +0200
commit899ef8bc40e9a3d11dcc881915580b79fcfc7c8a (patch)
tree1d4446ea145d2fb9bff4b9a5bbeec32d2c1b16a9
parent35e71220dfdf71234e84cc7b6d03fce7c95cb22a (diff)
downloadaur-fatattr-git.tar.gz
build + source fixes
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--scons.patch12
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d62022a47a67..067156f99495 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = fatattr-git
pkgdesc = Small linux application to see or modify MSDOS attributes in a FAT file system
pkgver = r7.0d6431f
- pkgrel = 1
- url = https://github.com/Terseus/fatattr
+ pkgrel = 2
+ url = https://gitlab.com/Terseus/fatattr
arch = x86_64
arch = i686
arch = arm
@@ -15,8 +15,9 @@ pkgbase = fatattr-git
makedepends = clang
provides = fatattr
conflicts = fatattr
- source = fatattr-git::git+https://github.com/Terseus/fatattr.git#branch=master
+ source = fatattr-git::git+https://gitlab.com/Terseus/fatattr.git#branch=master
+ source = scons.patch
md5sums = SKIP
+ md5sums = 1e4b2764a0940840bb842ac83ff5e655
pkgname = fatattr-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ce2b3a902ed8..bb5fc7719c52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: noirscape <deepnavy at waifu dot club>
pkgname=fatattr-git # '-bzr', '-git', '-hg' or '-svn'
pkgver=r7.0d6431f
-pkgrel=1
+pkgrel=2
pkgdesc="Small linux application to see or modify MSDOS attributes in a FAT file system"
arch=("x86_64" "i686" "arm" "armv6h" "armv7h" "aarch64")
-url="https://github.com/Terseus/fatattr"
+url="https://gitlab.com/Terseus/fatattr"
license=('GPL')
depends=()
makedepends=('git' 'scons' 'clang') # 'bzr', 'git', 'mercurial' or 'subversion'
provides=("fatattr")
conflicts=("fatattr")
-source=("$pkgname"::'git+https://github.com/Terseus/fatattr.git#branch=master')
-md5sums=('SKIP')
+source=("$pkgname"::'git+https://gitlab.com/Terseus/fatattr.git#branch=master' "scons.patch")
+md5sums=('SKIP'
+ '1e4b2764a0940840bb842ac83ff5e655')
+
+prepare() {
+ cd "$srcdir/${pkgname%-VCS}"
+ patch --forward --strip=1 --input="${srcdir}/scons.patch"
+}
pkgver() {
cd "$srcdir/${pkgname%-VCS}"
diff --git a/scons.patch b/scons.patch
new file mode 100644
index 000000000000..db51f6bb35d4
--- /dev/null
+++ b/scons.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text fatattr-git/SConstruct fatattr-git.new/SConstruct
+--- fatattr-git/SConstruct 2021-06-23 15:01:11.901818255 +0200
++++ fatattr-git.new/SConstruct 2021-06-23 15:02:16.761816121 +0200
+@@ -69,7 +69,7 @@
+ print("%s => '%s'" % (name, varlist[name]))
+ if V_PRINTENV > 1:
+ print("Dumping SCons environment...")
+- print env.Dump()
++ print(env.Dump())
+ exit(0)
+
+ dosfs_o = env.Object(V_DOSFS_C)