summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-05-13 20:34:05 +0200
committerMichal Wojdyla2021-05-13 20:34:05 +0200
commit96570aaf6219fbff3843c514bfc96043115f5eb6 (patch)
tree3185326ffc837da6b5f9868e438f82264feabd0b
parent4b0e1dc8379edf6eeb4c637ab5e55e65a82e7529 (diff)
downloadaur-fbautostart.tar.gz
fix license
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD11
3 files changed, 7 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d32ef69e92b..59c0520f71bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
-# Generated by mksrcinfo v8
-# Mon Dec 14 14:43:37 UTC 2015
pkgbase = fbautostart
pkgdesc = Lightweight XDG autostarter for Fluxbox
pkgver = 2.718281828
- pkgrel = 2
+ pkgrel = 3
url = https://launchpad.net/fbautostart
arch = i686
arch = x86_64
- license = BSD
+ license = MIT
depends = gcc-libs
source = https://launchpad.net/fbautostart/fbautostart/2.718281828/+download/fbautostart-2.718281828.tar.gz
- source = LICENSE
md5sums = 06495f9b23b1c9b1bf35c2346cb48f63
- md5sums = 3b20fd23a403ee99b09928d2c3b70e19
pkgname = fbautostart
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 1c53b3bb783b..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,26 +0,0 @@
-Copyright: 2010-2012, Paul Tagliamonte <paultag@ubuntu.com>
-License: BSD-3
- Redistribution and use in source and binary forms, with or without
- modification, are permitted provided that the following conditions
- are met:
- .
- 1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
- 2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
- 3. Neither the name of the University nor the names of its contributors
- may be used to endorse or promote products derived from this software
- without specific prior written permission.
- .
- THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
- ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
- IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
- ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
- FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
- DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
- OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
- HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
- LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
- OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
- SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 8004d7733175..a3c53ff15008 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=fbautostart
pkgver=2.718281828
-pkgrel=2
+pkgrel=3
pkgdesc="Lightweight XDG autostarter for Fluxbox"
arch=('i686' 'x86_64')
url="https://launchpad.net/fbautostart"
depends=('gcc-libs')
-license=('BSD')
-source=("https://launchpad.net/$pkgname/$pkgname/$pkgver/+download/$pkgname-$pkgver.tar.gz" "LICENSE")
-md5sums=('06495f9b23b1c9b1bf35c2346cb48f63'
- '3b20fd23a403ee99b09928d2c3b70e19')
+license=('MIT') #looks like MIT, launchpad says it's GNU GPL v3
+source=("https://launchpad.net/$pkgname/$pkgname/$pkgver/+download/$pkgname-$pkgver.tar.gz")
+md5sums=('06495f9b23b1c9b1bf35c2346cb48f63')
build() {
cd $pkgname-$pkgver
@@ -20,7 +19,7 @@ build() {
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" install
- install -Dm644 $startdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 COPYRIGHT $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
# vim:set ts=2 sw=2 et: