summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulia2022-04-03 17:12:59 +0200
committerJulia2022-04-03 17:12:59 +0200
commit1ea226b93d0cd4fd571f0c9dbcdf32237faf8b2e (patch)
tree9cbdc7a80cf127caf01153d11944a150095f12e3
parentbb7813301eea4a5cf095d17ff4e9cdf808aa5930 (diff)
downloadaur-fbkeyboard.tar.gz
Added arch linux font location patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--patch-archlinux-font-dir.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97ded36a985c..0b1eeca84796 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = fbkeyboard
pkgdesc = A framebuffer softkeyboard for touchscreen devices
pkgver = 0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bakonyiferenc/fbkeyboard
arch = any
license = GPL3
source = https://github.com/bakonyiferenc/fbkeyboard/archive/refs/tags/0.4.zip
+ source = patch-archlinux-font-dir.patch
sha256sums = ad05e22d6fc1c74f44e7fb3a2b4578c2650d1a09a012237d444e4e7938a023b5
+ sha256sums = 37ac258adce9085de2d858e6b04b05a459edcbd086018e49a706933d9e68f4c2
pkgname = fbkeyboard
diff --git a/PKGBUILD b/PKGBUILD
index b41c9419b2d4..852c022f7d7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,19 @@
# Maintainer: Julia <juliag2 (at) protonmail (dot) com>
pkgname=fbkeyboard
pkgver=0.4
-pkgrel=1
+pkgrel=2
pkgdesc="A framebuffer softkeyboard for touchscreen devices"
arch=(any)
url="https://github.com/bakonyiferenc/fbkeyboard"
license=('GPL3')
-source=("https://github.com/bakonyiferenc/$pkgname/archive/refs/tags/$pkgver.zip")
-sha256sums=("ad05e22d6fc1c74f44e7fb3a2b4578c2650d1a09a012237d444e4e7938a023b5")
+source=("https://github.com/bakonyiferenc/$pkgname/archive/refs/tags/$pkgver.zip"
+ "patch-archlinux-font-dir.patch")
+sha256sums=("ad05e22d6fc1c74f44e7fb3a2b4578c2650d1a09a012237d444e4e7938a023b5"
+ "37ac258adce9085de2d858e6b04b05a459edcbd086018e49a706933d9e68f4c2")
build() {
cd "$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir"/patch-archlinux-font-dir.patch
make
}
diff --git a/patch-archlinux-font-dir.patch b/patch-archlinux-font-dir.patch
new file mode 100644
index 000000000000..9aef2f689a9c
--- /dev/null
+++ b/patch-archlinux-font-dir.patch
@@ -0,0 +1,11 @@
+--- /fbkeyboard.c 2020-07-11 06:41:57.000000000 +0200
+--- /fbkeyboard.c 2022-04-03 16:56:07.240059480 +0200
+@@ -34,7 +34,7 @@
+
+ volatile sig_atomic_t done = 0;
+
+-char *font = "/usr/share/fonts/ttf-dejavu/DejaVuSans.ttf";
++char *font = "/usr/share/fonts/TTF/DejaVuSans.ttf";
+ char *device = NULL;
+ char *special[][7] = {
+ { "Esc", "Tab", "F10", " / ", " - ", " . ", " \\ " },