summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Sabota2020-12-14 16:46:44 -0500
committerLukas Sabota2020-12-14 16:46:44 -0500
commite877de7aa3c65de2fb307d6543669dc5536acd25 (patch)
tree4f0cebd39a7e0846b07f3f78593100eaf38d1c75
parent119388fabc8298555923d73bf9340949e4844cc6 (diff)
downloadaur-e877de7aa3c65de2fb307d6543669dc5536acd25.tar.gz
use cmake
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 754723ada994..23ba2f13b2ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = fceux-git
pkgdesc = Fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support
- pkgver = e8c61d1b
+ pkgver = 2.2.3.1633.gf333a62d
pkgrel = 1
url = http://fceux.com/
arch = i686
arch = x86_64
license = GPL
makedepends = git
- makedepends = scons
+ makedepends = cmake
makedepends = libgl
makedepends = glu
depends = sdl
diff --git a/PKGBUILD b/PKGBUILD
index 683a1681ca79..83cbdf8f0ac1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
pkgname=fceux-git
-pkgver=e8c61d1b
+pkgver=2.2.3.1633.gf333a62d
pkgrel=1
pkgdesc="Fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support"
arch=('i686' 'x86_64')
url="http://fceux.com/"
license=('GPL')
depends=('sdl' 'lua51' 'gtk2' 'gd' 'libgl')
-makedepends=('git' 'scons' 'libgl' 'glu')
+makedepends=('git' 'cmake' 'libgl' 'glu')
optdepends=('xchm: for viewing the help manual')
provides=('fceux')
conflicts=('fceux')
@@ -17,22 +17,23 @@ md5sums=('SKIP')
pkgver() {
cd fceux
- git describe --always| sed 's/-/./g'
+ git describe --always| sed 's/-/./g' | sed 's/fceux.//'
}
build() {
cd fceux
-
- scons RELEASE=1
+ mkdir -p build
+ cd build
+ cmake ../
+ make
}
package() {
cd fceux
- install -D -m755 bin/fceux "$pkgdir/usr/bin/fceux"
- install -D -m755 bin/fceux-net-server "$pkgdir/usr/bin/fceux-net-server"
- install -D -m644 bin/fceux.chm "$pkgdir/usr/share/doc/fceux/fceux.chm"
+ install -D -m755 build/src/fceux "$pkgdir/usr/bin/fceux"
+ install -D -m644 output/fceux.chm "$pkgdir/usr/share/doc/fceux/fceux.chm"
install -D -m644 "fceux.desktop" "$pkgdir/usr/share/applications/fceux.desktop"
install -D -m644 "fceux.png" "$pkgdir/usr/share/pixmaps/fceux.png"
}