summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Sabota2015-07-15 15:09:10 -0400
committerLukas Sabota2015-07-15 15:09:10 -0400
commit18bb9618f1ac1ed72011d483db8e8ff254475989 (patch)
treec4d087e9d22b9912f40bb9241c99c05c156b6115
downloadaur-fceux-svn.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD53
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfdb317de8c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = fceux-svn
+ pkgdesc = Fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support
+ pkgver = 2888
+ pkgrel = 1
+ url = http://fceux.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ makedepends = scons
+ makedepends = libgl
+ makedepends = glu
+ depends = sdl
+ depends = lua51
+ depends = gtk2
+ depends = gd
+ depends = libgl
+ optdepends = xchm: for viewing the help manual
+ provides = fceu
+ provides = gfceux
+ provides = fceux
+ conflicts = fceu
+ conflicts = gfceux
+ conflicts = fceux
+
+pkgname = fceux-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98c39dc665d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
+
+pkgname=fceux-svn
+pkgver=2888
+pkgrel=1
+pkgdesc="Fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support"
+arch=('i686' 'x86_64')
+url="http://fceux.com/"
+license=('GPL')
+depends=('sdl' 'lua51' 'gtk2' 'gd' 'libgl')
+makedepends=('subversion' 'scons' 'libgl' 'glu')
+optdepends=('xchm: for viewing the help manual')
+provides=('fceu' 'gfceux' 'fceux')
+conflicts=('fceu' 'gfceux' 'fceux')
+replaces=()
+backup=()
+options=()
+install=
+source=()
+noextract=()
+
+_svntrunk=http://svn.code.sf.net/p/fceultra/code/fceu/trunk
+_svnmod=fceu
+LDFLAGS=''
+
+build() {
+ cd "$srcdir"
+
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up -r $pkgver)
+ else
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_svnmod-build"
+ cp -r "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_svnmod-build"
+
+ scons RELEASE=1
+}
+
+package() {
+ cd "$srcdir/$_svnmod-build"
+
+ install -D -m755 bin/fceux "$pkgdir/usr/bin/fceux"
+ install -D -m755 bin/fceux-net-server "$pkgdir/usr/bin/fceux-net-server"
+ install -D -m644 bin/fceux.chm "$pkgdir/usr/share/doc/fceux/fceux.chm"
+ install -D -m644 "fceux.desktop" "$pkgdir/usr/share/applications/fceux.desktop"
+ install -D -m644 "fceux.png" "$pkgdir/usr/share/pixmaps/fceux.png"
+}