summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Eklöf2021-12-08 17:51:41 +0100
committerDaniel Eklöf2021-12-08 17:51:41 +0100
commitb070a10af8baa820db1c441424cd764039ed76b1 (patch)
tree431a4d8cf237f32936f2d885f52c3a74a3d87a7e
parentb25f1e6ef18b89efa0c1a0a206a90c714f7b0cda (diff)
downloadaur-fcft.tar.gz
Update to 2.5.1
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md29
-rw-r--r--PKGBUILD4
3 files changed, 34 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 366f8096c68c..e39ea6d44e98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fcft
pkgdesc = Simple library for font loading and glyph rasterization using FontConfig, FreeType and pixman.
- pkgver = 2.5.0
+ pkgver = 2.5.1
pkgrel = 1
url = https://codeberg.org/dnkl/fcft
changelog = CHANGELOG.md
@@ -18,7 +18,7 @@ pkgbase = fcft
depends = pixman
depends = harfbuzz
depends = libutf8proc
- source = fcft-2.5.0.tar.gz::https://codeberg.org/dnkl/fcft/archive/2.5.0.tar.gz
- sha256sums = 58663c684f04154674c52551daa604618e0bb3db6c62492b06b13768fb4f4b3c
+ source = fcft-2.5.1.tar.gz::https://codeberg.org/dnkl/fcft/archive/2.5.1.tar.gz
+ sha256sums = 1b9e9346c884f16bce9548806ea89c5e34ccc98ce27ec6ecff1f5011235de112
pkgname = fcft
diff --git a/CHANGELOG.md b/CHANGELOG.md
index ce7c8f4dbf6b..0196b6807b50 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,6 @@
# Changelog
+* [2.5.1](#2-5-1)
* [2.5.0](#2-5-0)
* [2.4.6](#2-4-6)
* [2.4.5](#2-4-5)
@@ -28,6 +29,34 @@
* [1.1.7](#1-1-7)
+## 2.5.1
+
+### Added
+
+* Meson command line option `-Ddocs` to force disable or enable
+ building manual pages and installing changelog and readme files
+
+
+### Changed
+
+* `scdoc` is optional and detected automatically
+* `fcft_set_scaling_filter()` now applies to color bitmap fonts only
+ (i.e. emoji fonts). Applying e.g. cubic or lanczos3 on regular text
+ glyphs simply does not look good.
+
+
+### Fixed
+
+* `FCFT_SCALING_FILTER_CUBIC` incorrectly being mapped to “lanczos3”.
+* Pixman errors and program freezes when scaling bitmap fonts to very
+ small sizes (https://codeberg.org/dnkl/foot/issues/830).
+
+
+### Contributors
+
+* Alibek Omarov
+
+
## 2.5.0
### Added
diff --git a/PKGBUILD b/PKGBUILD
index 70c5b812c9e6..58b72d502da5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ GRAPHEME_SHAPING=enabled # auto|disabled|enabled
RUN_SHAPING=enabled # auto|disabled|enabled
pkgname=fcft
-pkgver=2.5.0 # Don’t forget to update CHANGELOG.md
+pkgver=2.5.1 # Don’t forget to update CHANGELOG.md
pkgrel=1
pkgdesc="Simple library for font loading and glyph rasterization using FontConfig, FreeType and pixman."
arch=('x86_64' 'aarch64')
@@ -15,7 +15,7 @@ makedepends=('meson' 'ninja' 'scdoc' 'tllist')
checkdepends=('check' 'ttf-dejavu')
changelog=CHANGELOG.md
source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
-sha256sums=('58663c684f04154674c52551daa604618e0bb3db6c62492b06b13768fb4f4b3c')
+sha256sums=('1b9e9346c884f16bce9548806ea89c5e34ccc98ce27ec6ecff1f5011235de112')
if [[ ${RUN_SHAPING} == enabled ]]; then
depends+=('harfbuzz' 'libutf8proc')