summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Parent2015-08-22 14:55:40 -0500
committerJeff Parent2015-08-22 14:55:40 -0500
commitd931977cc66c43db203ac21fd8e3e88b8a4bc3e0 (patch)
treeed0495838e09905c6dae2ebc3560f7b67ab42062
downloadaur-feather-git.tar.gz
Rev 30.503fb9f
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE6
-rw-r--r--PKGBUILD36
-rw-r--r--feather.install7
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89de3abcf1c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = feather-git
+ pkgdesc = A tarsnap script that performs and maintains a set of backups as defined by a yaml configuration file
+ pkgver = 30.503fb9f
+ pkgrel = 1
+ url = https://github.com/danrue/feather
+ install = feather.install
+ arch = any
+ license = custom:beerware
+ makedepends = git
+ depends = tarsnap
+ depends = python2-yaml
+ source = git://github.com/danrue/feather.git
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 11e83d27bfac8416111b464909fc9adf
+
+pkgname = feather-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..003d0d142166
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,6 @@
+ "THE BEER-WARE LICENSE" (Revision 43):
+
+ <drue@therub.org> wrote this file. As long as you retain this notice and
+ never sue us for anything, you can do whatever you want with this stuff.
+ If we meet some day, and you think this stuff is worth it, you can buy me
+ a beer in return. -Dan Rue
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9660695d1c3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Clément Junca <cju.arch@gmail.com>
+# Maintainer: Jeff Parent <jecxjo@sdf.lonestar.org>
+pkgname=feather-git
+pkgver=30.503fb9f
+pkgrel=1
+pkgdesc="A tarsnap script that performs and maintains a set of backups as defined by a yaml configuration file"
+arch=('any')
+url="https://github.com/danrue/feather"
+license=('custom:beerware')
+depends=('tarsnap' 'python2-yaml')
+makedepends=('git')
+install='feather.install'
+source=('git://github.com/danrue/feather.git'
+ 'LICENSE')
+md5sums=('SKIP'
+ '11e83d27bfac8416111b464909fc9adf')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-*}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-*}"
+ sed -i 's|env python|env python2|' feather
+ sed -i 's|binpath: /usr/local/bin/|binpath: /usr/bin/|' feather.yaml.dist
+}
+
+package() {
+ cd "$srcdir/${pkgname%-*}"
+ install -D -m755 feather "$pkgdir/usr/bin/feather"
+ install -D -m644 feather.yaml.dist "$pkgdir/usr/share/$pkgname/feather.yaml.dist"
+ install -D -m644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/feather.install b/feather.install
new file mode 100644
index 000000000000..1358eef45509
--- /dev/null
+++ b/feather.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Feather is designed to be run from cron like this:"
+ echo " */5 * * * * /usr/bin/feather path/to/config.yaml"
+ echo "However, NO out of the box configuration file comes with this package."
+ echo "You can copy an example file from /usr/share/feather-git/feather.yaml.dist,"
+ echo "modify it to your needs and change to cron line accordingly."
+}