summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreDgar2023-09-25 12:23:48 +0200
committereDgar2023-09-25 12:24:53 +0200
commit623c5c91c6656a32e30e010d8d4b707cb36dde14 (patch)
tree7f91023e4c8ef26c68e0ae7ceb138379633998f7
parent788660c51bb632b2078f7e813a326cd05c7eb00f (diff)
downloadaur-623c5c91c6656a32e30e010d8d4b707cb36dde14.tar.gz
depend on gcc, blas-openblas; branch=release in source, not prepare; needs manual tweak
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79835ab83f85..34b91c845cbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fenics-basix-git
pkgdesc = Interface of FEniCS for ordinary and partial differential equations (C++ and Python from git release).
pkgver = 0.6.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/FEniCS/basix
arch = i686
arch = x86_64
@@ -12,10 +12,12 @@ pkgbase = fenics-basix-git
makedepends = boost
makedepends = python-setuptools
makedepends = pybind11
+ makedepends = gcc
depends = xtensor
depends = xtensor-blas
depends = petsc
depends = python-numpy
+ depends = blas-openblas
provides = basix=0.6.0
provides = python-basix=0.6.0
provides = python-basix-git=0.6.0
@@ -26,7 +28,7 @@ pkgbase = fenics-basix-git
conflicts = python-fenics-basix
replaces = basix=0.6.0
options = !emptydirs
- source = git+https://github.com/FEniCS/basix
+ source = git+https://github.com/FEniCS/basix#branch=release
source = 0001-local-build-for-Python.patch
sha512sums = SKIP
sha512sums = 68798ec16666289131bec093a9b5f762569f2dbc9fa6d537dc5d9573abb6faa07791091cf4f12f2ce41798cd8e8b506311be3f2f55ce63cc28e3f91586a7b549
diff --git a/PKGBUILD b/PKGBUILD
index cad96fd355bb..027d76595469 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
-# Maintainer: entschuld <edgr@openmail.cc>
+# Maintainer: entschuld < edgar -a t . openmail.cc>
pkgname=fenics-basix-git
_base=basix
pkgdesc="Interface of FEniCS for ordinary and partial differential equations (C++ and Python from git release)."
pkgver=0.6.0
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
url="https://github.com/FEniCS/basix"
license=('MIT')
groups=('fenics-git')
-depends=('xtensor' 'xtensor-blas' 'petsc' "python-numpy")
-makedepends=('git' 'boost' 'python-setuptools' "pybind11")
+depends=('xtensor' 'xtensor-blas' 'petsc' "python-numpy" "blas-openblas")
+makedepends=('git' 'boost' 'python-setuptools' "pybind11" "gcc")
checkdepends=("python-sympy")
options=(!emptydirs)
-source=("git+${url}"
+source=("git+${url}#branch=release"
"0001-local-build-for-Python.patch")
sha512sums=('SKIP'
'68798ec16666289131bec093a9b5f762569f2dbc9fa6d537dc5d9573abb6faa07791091cf4f12f2ce41798cd8e8b506311be3f2f55ce63cc28e3f91586a7b549')
@@ -104,10 +104,9 @@ export LC_ALL=en_IE.UTF-8
_base_dir="${startdir}"/src/"${_base}"
prepare() {
- cd "${_base_dir}"
- git checkout origin/release
- # git apply "${srcdir}"/0001-local-build-for-Python.patch
git -C "${_base_dir}" clean -dfx
+ # Manually add
+ # #include <cstdint> to src/basix/cpp/basix/finite-element.h
}
pkgver() {