summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreDgar2024-01-05 14:14:01 +0100
committereDgar2024-01-05 14:14:01 +0100
commit652b0d7cc2e1be4442ef8c083ad635190a500191 (patch)
tree406904485fd6f3e5d30b72d8be95b38b2b8baeed
parenta2f0cb7bf6b0562f11d314af14ceee6afc714fd4 (diff)
downloadaur-652b0d7cc2e1be4442ef8c083ad635190a500191.tar.gz
upd8 depends
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b56404ff62d0..692eece16f09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fenics-basix-git
pkgdesc = C++ interface of FEniCS for ordinary and partial differential equations (from git release).
- pkgver = 0.8.0.dev0_r952.eebbc52
+ pkgver = 0.8.0.dev0_r993.9886b33
pkgrel = 1
url = https://github.com/FEniCS/basix
arch = i686
@@ -8,20 +8,19 @@ pkgbase = fenics-basix-git
groups = fenics-git
license = MIT
checkdepends = python-sympy
+ checkdepends = petsc
makedepends = boost
makedepends = gcc
makedepends = git
- makedepends = pybind11
+ makedepends = nanobind
makedepends = python-build
makedepends = python-installer
- makedepends = python-numpy
makedepends = python-scikit-build
+ makedepends = python-scikit-build-core
makedepends = python-setuptools
- makedepends = nanobind
depends = blas-openblas
- depends = petsc
- depends = xtensor
- depends = xtensor-blas
+ depends = python-numpy
+ optdepends = openmpi
provides = basix
provides = fenics-basix
conflicts = basix
diff --git a/PKGBUILD b/PKGBUILD
index 30da175258e2..028666c9af13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,19 @@
_base=basix
pkgname=fenics-"${_base}"-git
pkgdesc="C++ interface of FEniCS for ordinary and partial differential equations (from git release)."
-pkgver=0.8.0.dev0_r952.eebbc52
+pkgver=0.8.0.dev0_r993.9886b33
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/FEniCS/${_base}"
license=('MIT')
groups=('fenics-git')
-depends=("blas-openblas" "petsc" "xtensor" "xtensor-blas")
-makedepends=("boost" "gcc" "git" "pybind11" "python-build" "python-installer" "python-numpy" "python-scikit-build" "python-setuptools" "nanobind")
-checkdepends=("python-sympy")
+depends=("blas-openblas" "python-numpy")
+makedepends=(
+ "boost" "gcc" "git" "nanobind" "python-build"
+ "python-installer" "python-scikit-build"
+ "python-scikit-build-core" "python-setuptools")
+optdepends=("openmpi")
+checkdepends=("python-sympy" "petsc")
options=(!emptydirs)
source=("git+${url}#branch=main")
sha512sums=('SKIP')